Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2562    Accepted Submission(s): 1056
Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the
living habit of a scorpion like living underground and digging holes.



Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis
has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely
Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 
Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of
equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 
Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 
Sample Input
2 20 3
10 20
3 10
1 7 10 2
1 10
2 11
 
Sample Output
Yes
No
 
分析:

                       停放体积 移动体积

第一件物品   a1     b1

第二件物品   a2     b2

如果这两件物品的移动体积都不大于洞的体积V

a1+b2为先放第一件物品 后放第二件物品的最大瞬时体积

a2+b1为先放第二件物品 后放第一件物品的最大瞬时体积

我们应该选择a1+b2和a2+b1中比較小的先放.


如果n件物品的移动体积都不大于洞的体积V(如果有大于的 那么结果必定是NO)

将N件物品依照a1+b2<a2+b1进行排序,然后依次放入洞中。即依照差值从大到小放入洞中.

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std; struct node
{
int x,y;
}p[10005]; bool cmp(node a,node b) // 差值排序
{
return (a.y-a.x)>(b.y-b.x);
} int main ()
{
int t,n,m,i,j;
int flag;
scanf("%d",&t);
for(i=0;i<t;i++)
{
scanf("%d%d",&n,&m);
for(j=0;j<m;j++)
scanf("%d%d",&p[j].x,&p[j].y);
sort(p,p+m,cmp);
flag=1;
for(j=0;j<m;j++)
{
if(p[j].y>n)
{
flag=0;
break;
}
n-=p[j].x;
}
if(flag) printf("Yes\n");
else printf("No\n");
}
return 0; }


最新文章

  1. JMeter常用测试元件—学习笔记
  2. CSS布局技巧 -- 各种居中
  3. zend stuido 12.5的插件安装和xdebug调试器的配置和和配置注意
  4. MessageFormat用法
  5. JavaScript执行bat文件清理浏览器缓存
  6. spring注解配置启动过程
  7. 关于java文件扩展名认识
  8. BZOJ3397: [Usaco2009 Feb]Surround the Islands 环岛篱笆
  9. SpotMini末端控制策略
  10. javascript如何判断访问网页的设备及是否支持触屏功能
  11. boost json生成和解析用法
  12. rsyslog 日志归类思路--根据syslog local5 nginx-zjzc01;
  13. hdu_5761_Rower Bo(xjb猜公式)
  14. iOS开发之UITableView及cell重用
  15. 高通msm8994手动提升性能脚本
  16. Linux 文件/文件夹无法删除问题解决方案
  17. 四十九、进程间通信——System V IPC 之消息队列
  18. 6.linux安装tomcat
  19. 14.并发与异步 - 3.C#5.0的异步函数 -《果壳中的c#》
  20. idea 优先引用项目代码,而非jar包

热门文章

  1. FH Admin
  2. N数码问题的启发式搜索算法--A*算法python实现
  3. Codeforces Round #198 (Div. 2)E题解
  4. 如何正确产看API
  5. css中常用的七种三栏布局技巧总结
  6. 腾讯新闻多图jQuery相册展示效果代码
  7. lz的第一个RN项目
  8. 01--Qt扫盲篇
  9. associatedtype关联类型
  10. IOS Html富文本渲染方式:DTCoreText、WKWebView、UIWebView的内存占用对比