Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16242    Accepted Submission(s): 11445

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.



"The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+...+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 
Sample Input
4
10
20
 
Sample Output
5
42
627
 
Author
Ignatius.L

#include<stdio.h>
#include<string.h>
#define max 100+30
int main()
{
int c1[max],c2[max];
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<=n;i++)
{
c1[i]=1;
c2[i]=0;
}
for(int i=2;i<=n;i++)//从第二个多项式开始乘
{
for(int j=0;j<=n;j++)//在第一个多项式中的每一项与后边的相乘
for(int k=0;k+j<=n;k+=i)//在第i个多项式中的每一项与前边的相乘
c2[k+j]+=c1[j];
for(int j=0;j<=n;j++)
{
c1[j]=c2[j];//更新现在第一个多项式中的每一项的系数
c2[j]=0;
}
}
printf("%d\n",c1[n]);
}
return 0;
}

最新文章

  1. bzoj4559: [JLoi2016]成绩比较
  2. linux桌面的安装
  3. 挂载光盘与rpm安装
  4. [原创]配置管理技术圈QQ群:129489184
  5. poj 1804 (nyoj 117)Brainman : 归并排序求逆序数
  6. 窗口截图(可指定HWND窗口句柄)(三篇文章)
  7. C# JackLib系列之Form窗体的ShowWithoutActivation属性及其作用
  8. PEAR:使用PHPDoc轻松建立你的PEAR文档
  9. js 动态添加元素(div、li、img等)及设置属性
  10. 优秀Android开源项目
  11. java 不同意同一账户不同IP 同一时候登录系统解决的方法 兼容IE Firefox
  12. web开发在线调试
  13. swift3.0 coreData的使用-日记本demo
  14. 【一天一道LeetCode】#70. Climbing Stairs
  15. PHP Request请求封装
  16. shell脚本语法学习
  17. iptables概述
  18. windows下安装pycharm并连接Linux的python环境
  19. Oracle存储过程和自定义函数笔记
  20. 通过cookie验证用户登录

热门文章

  1. BZOJ 3992 DP+NTT+快速幂
  2. C - Young Physicist
  3. 4.Projects and Scenes介绍
  4. 6) 十分钟学会android--Activity的生命周期之启动与销毁
  5. houxiurong.com 关于Tomcat7部署 一台机器部署两个项目,一个用域名访问,一个用IP访问
  6. 杭电 1013 Digital Roots
  7. SDL2源代码分析
  8. Drop it FreeCodeCamp
  9. Linux下mysql 忘记密码的解决办法
  10. mysql笔记1------基础