Time Limit: 2000MS   Memory Limit: 262144KB   64bit IO Format: %I64d & %I64u

Submit
Status

Description

Carl is a beginner magician. He has a blue,
b violet and c orange magic spheres. In one move he can transform two spheres
of the same color into one sphere of any other color. To make a spell that has never been seen before, he needs at least
x blue, y violet and
z orange spheres. Can he get them (possible, in multiple actions)?

Input

The first line of the input contains three integers a,
b and c (0 ≤ a, b, c ≤ 1 000 000) — the number of blue, violet and orange spheres that are in the magician's disposal.

The second line of the input contains three integers, x,
y and z (0 ≤ x, y, z ≤ 1 000 000) — the number of blue, violet and orange spheres that he needs to get.

Output

If the wizard is able to obtain the required numbers of spheres, print "Yes". Otherwise, print "No".

Sample Input

Input
4 4 0
2 1 2
Output
Yes
Input
5 6 1
2 7 2
Output
No
Input
3 3 3
2 2 2
Output
Yes

Sample Output

Hint

In the first sample the wizard has 4 blue and
4 violet spheres. In his first action he can turn two blue spheres into one violet one. After that he will have
2 blue and 5 violet spheres. Then he turns
4 violet spheres into 2 orange spheres and he ends up with
2 blue, 1 violet and
2 orange spheres, which is exactly what he needs.

Source


现在给你a,b,c个不同颜色的球,神魔颜色我也不知道,两个相同颜色的可以得到一个任意颜色的,问现在是否可以得到x,y,z,个三种颜色的球
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a,b,c,x,y,z;
long long ans,pre;
int main()
{
while(scanf("%d%d%d%d%d%d",&a,&b,&c,&x,&y,&z)!=EOF)
{
ans=pre=0;
int p,q,r;
p=q=r=0;
if(a-x>=0) p=0,pre+=(a-x)/2;
else p=a-x;
if(b-y>=0) q=0,pre+=(b-y)/2;
else q=b-y;
if(c-z>=0) r=0,pre+=(c-z)/2;
else r=c-z;
// printf("%d\n",pre);
// printf("%d %d %d\n",p,q,r);
if(pre+p+q+r>=0) printf("Yes\n");
else printf("No\n");
}
return 0;
}

最新文章

  1. android开发读书笔记
  2. SQL Server 更改跟踪(Chang Tracking)监控表数据
  3. Java多线程学习笔记
  4. RecyclerView使用
  5. Spearman Rank(斯皮尔曼等级)相关系数及MATLAB实现
  6. 流媒体(音频 AudioStreamer)
  7. 单页Web应用:
  8. 设计模式C#实现(四)——迭代器模式
  9. StringUtil
  10. 20145129 《Java程序设计》第5周学习总结
  11. 转:C语言申请内存时堆栈大小限制
  12. GSM Channel Mode Modify和Channel Mode Modify Acknowledge信令
  13. JS代码混淆 支持PHP .NET PERL
  14. TCP/IP详解学习笔记 这位仁兄写得太好了
  15. Lesser known purrr tricks
  16. C#编写街道管理系统
  17. 微信小程序快捷键
  18. B树和B+树的插入、删除图文详解
  19. 【shell脚本】ftp自动上传mysql备份文件
  20. Java的String和StringBuilder

热门文章

  1. website robots.txt 防爬虫 措施
  2. 洛谷P2851 [USACO06DEC]最少的硬币The Fewest Coins(完全背包+多重背包)
  3. jquery mobile动态加载数据后无法渲染
  4. ML一:python的KNN算法
  5. linux中errno使用(转)
  6. jquery里面的一些方法
  7. 【udacity】机器学习-2模型验证
  8. 完全二叉树(Complete Binary Tree)
  9. Python数据分析5-----数据规约
  10. Django:URL,Views,Template,Models