zk has n numbers a1,a2,...,ana1,a2,...,an. For each (i,j) satisfying 1≤i<j≤n, zk generates a new number (ai+aj)(ai+aj). These new numbers could make up a new sequence b1,b2,...,bn(n−1)/2b1,b2,...,bn(n−1)/2. 

LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk. 

Can you help zk find out which n numbers were originally in a?

Input

Multiple test cases(not exceed 10). 

For each test case: 

∙∙The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2. 

∙∙The second line contains m numbers, indicating the mixed sequence of a and b. 

Each aiai is in [1,10^9]

Output

For each test case, output two lines. 

The first line is an integer n, indicating the length of sequence a; 

The second line should contain n space-seprated integers a1,a2,...,an(a1≤a2≤...≤an)a1,a2,...,an(a1≤a2≤...≤an). These are numbers in sequence a. 

It's guaranteed that there is only one solution for each case.

Sample Input

6
2 2 2 4 4 4
21
1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11

Sample Output

3
2 2 2
6
1 2 3 4 5 6

这个看代码吧。QAQ

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int n,m;
vector <int> a,b,c,ans;
map <int,int> mmp;
int main()
{
while(~scanf("%d",&n))
{
a.clear();
b.clear();
c.clear();
ans.clear();
mmp.clear();
int temp;
for(int i=0;i<n;i++)
{
scanf("%d",&temp);
a.push_back(temp);
if(mmp[temp]==0) mmp[temp]=1;
else mmp[temp]++; }
sort(a.begin(),a.end());
ans.push_back(a[0]);
for(int i=1;i<n;i++)
{
if(mmp[a[i]]==0) continue;
for(int j=0;j<ans.size();j++)
{
mmp[ans[j]+a[i]]--;
}
ans.push_back(a[i]);
mmp[a[i]]--;
} printf("%d\n",ans.size());
vector <int> ::iterator it;
for(it=ans.begin();it!=ans.end();it++)
{
if(it==ans.begin()) cout<<*it;
else cout<<" "<<*it;
}
cout<<endl;
}
return 0;
}

最新文章

  1. 耿丹CS16-2班第四次作业汇总
  2. js实现继承的方式总结
  3. win32控制台消息机制
  4. Heritrix源码分析(五) 如何让Heritrix在Ecplise等IDE下编程启动(转)
  5. js2word/html2word的简单实现
  6. C#_约束 实现可排序单链表
  7. .net软件工程师面试题(参考答案)
  8. 伪元素first-letter(首字母变大)
  9. linux中curl命令
  10. Android之——Fragment生命周期(日志截图版)
  11. ASM实现Android APK的AOP日志统计
  12. Charlse 使用小记
  13. Linux 多线程下载工具:axel
  14. 前端的UI设计与交互之数据录入篇
  15. Java经典面试题+答案(全)
  16. 记录一次DataTable排序的问题
  17. 【nodejs】让nodejs像后端mvc框架(asp.net mvc)一样处理请求--参数自动映射篇(6/8)
  18. 第11课 std::bind和std::function(2)_std::bind绑定器
  19. 转:display:flex不兼容Android、Safari低版本的解决方案 【flex布局】
  20. jdk tomcat maven svn plsql客户端 环境变量配置整理

热门文章

  1. canvas画圆环%显示
  2. tp5验证码的使用
  3. pat 1042 Shuffling Machine(20 分)
  4. 力扣(LeetCode)从不订购的客户-数据库题 个人题解
  5. x86汇编分页模式实验 --《ORANGE&#39;S一个操作系统的实现》中 pmtest8.asm解析
  6. Vue 指令总结大全
  7. CBO优化器实用理解
  8. python的reduce,map,zip,filter和sorted函数
  9. ctf比赛linux文件监控和恢复shell
  10. 在Kubernetes上运行有状态应用:从StatefulSet到Operator