http://acm.hdu.edu.cn/showproblem.php?pid=2795

Billboard

Problem Description
 
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 
Input
 
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 
Output
 
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 
Sample Input
 
3 5 5
2
4
3
3
3
 
Sample Output
 
1
2
1
3
-1
#include <cstdio>
#include <cstring>
using namespace std;
#define N 200005
#define lson rt<<1,l,m
#define rson rt<<1|1,m+1,r
struct node
{
int value;
}tree[N<<];
/*
线段树
记得要用h和n的较小值来建树
思路比较难想:每个区间的value装的是该区间还能放下的最大长度
然后与输入进来的len进行比较
题意要求优先放左边,所以如果左儿子放得下优先放左儿子,不然看右儿子
然后要PushUp更新父节点信息
如果根节点即第一个节点放不下,即整棵树必定没有一个区间可以放得下该广告
*/
void Build(int rt,int l,int r,int k)
{
tree[rt].value=k;
if(l==r) return ;
int m=(l+r)>>;
Build(lson,k);
Build(rson,k);
} int Query(int rt,int l,int r,int len)
{
int ans;
if(l==r){
tree[rt].value-=len;
return l;
}
int m=(l+r)>>;
//如果左边能放下,优先放左边,不然看右边能不能放下
if(tree[rt<<].value>=len) ans=Query(lson,len);
else ans=Query(rson,len);
// tree[rt].value=max(tree[rt<<1].value,tree[rt<<1|1].value);
//PushUp
if(tree[rt<<].value>=tree[rt<<|].value)
tree[rt].value=tree[rt<<].value;
else tree[rt].value=tree[rt<<|].value;
return ans;
} int main()
{
int h,w,n;
while(~scanf("%d%d%d",&h,&w,&n)){
if(h>n) h=n;
Build(,,h,w);
while(n--){
int len;
scanf("%d",&len);
if(tree[].value<len) printf("-1\n");
else printf("%d\n",Query(,,h,len));
}
}
return ;
}

最新文章

  1. 金字塔Lucas-Kanande光流算法实现
  2. NHibernate实例化类部分属性
  3. !!Python字典增删操作技巧简述+Python字典嵌套字典与排序
  4. magento获取一些值的方法函数
  5. 【Luogu1393】动态逆序对(CDQ分治)
  6. Java——final关键字
  7. 周强 201771010141《面对对象程序设计(java)》第十周学习总结
  8. codeforces104A
  9. Docker的离线安装
  10. YOLO(5) YOLO2 代码讲解
  11. 一次学生时代的经历,利用Python在机房杀红蜘蛛,脱离老师控制!
  12. ARMV8 datasheet学习笔记4:AArch64系统级体系结构之VMSA
  13. Python图形编程探索系列-05-用控制变量构建对话程序
  14. 吴伯凡:VUCA时代的自我迭代
  15. Entity Framework 5中遇到的 mysql tinyint(1) 转换为 bool 的问题 (我用的是VS2013中的EF5版本)
  16. CocoaAsyncSocket UDP发送数据超过包大小限制(Message too long)
  17. html_table表格
  18. iOS:多个单元格的删除(方法一)
  19. FTP安装
  20. Nginx+tomcat配置负载均衡集群

热门文章

  1. wpf C# 操作DirectUI窗口 SendMessage+MSAA
  2. c# wpf 利用截屏键实现截屏功能
  3. 如何获取app配置文件内容
  4. siliverlight某些事件无法响应
  5. 如何快速生成数据文件(fsutil命令,使用CreateFile和SetEndOfFile API函数,fopen和fseek RTL函数)
  6. 如何将svg转换为xaml
  7. Win8 Metro(C#)数字图像处理--2.41彩色图像密度分割算法
  8. Qt 下快速读写Excel指南(尘中远)
  9. 面向对象编程(Object Oriented Programming,OOP,面向对象程序设计)
  10. C#爬虫与反爬虫--字体加密篇