这个估计是里面第二简单的了,因为第一简单的是求a+b

哈哈,一submit就ac了

题目如下:

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length.

(We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card

length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can

make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by

1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
 
简单的归结就是一个级数求和的问题
#include <iostream>
using namespace std; class Overhang {
private:
double a;
public:
int getCardsNum();
void getValue() { cin >> a; }
double geta() { return a; }
}; int Overhang::getCardsNum() {
int num=1;
double sum=0.0;
while(true) {
sum += 1.0/(num+1);
num++;
if (sum >= a)
return --num;
}
}
int main(void) {
Overhang t;
while(true) {
t.getValue();
if ((t.geta() - 0.0) < 0.0001)
return 0;
cout << t.getCardsNum() << " card(s)" << endl;
}
}

最新文章

  1. [Tool] github 入手教程
  2. Bzoj1176 [Balkan2007]Mokia
  3. tensrflow python [defunct]
  4. 软件工程day4
  5. 修改vb程序图标
  6. Foundation框架—字符串
  7. ckplayer播放器去掉右边的开关灯分享插件
  8. git-gui
  9. 实现OAUTH协议 实现 QQ 第三方登录效果
  10. windows环境下安装python模块大招
  11. 内部类&amp;匿名内部类
  12. Tomcat- java.lang.NoSuchMethodException: org.apache.catalina.deploy.WebXml addServlet
  13. 掌握JS
  14. Unity UGUI在鼠标位置不同时 图片浮动效果
  15. dubbo filter实现接口认证springboot idea
  16. 再探haproxy
  17. nginx 日志切割脚本
  18. Hadoop — Yarn原理解析
  19. Java的static类
  20. [AWS] OAuth2.0

热门文章

  1. HDUOJ-----2175取(m堆)石子游戏
  2. 【js与jquery】jquery循环滚动新闻
  3. Windows2008R2允许多用户远程登录设置
  4. C语言宏高级用法
  5. Python center() 方法
  6. HTTP请求流程(二)----Telnet模拟HTTP请求
  7. powerdesigner学习笔记【转载】
  8. Testbench
  9. Scala first trial
  10. vim:查看当前的配置文件名称和地址