1940. Ordering Tasks

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

There are multiple test cases. The first line contains an integer T, indicating the number of test cases. Each test case begins with a line containing two integers, 1 <= n <= 100000 and 1 <= m <= 100000. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. It is guaranteed that no task needs to be executed before itself either directly or indirectly.

Output

For each test case, print a line with n integers representing the tasks in a possible order of execution. To separate them, print exactly one space after each integer. If there are multiple solutions, output the smallest one by lexical order.

Sample Input

1
5 5
3 4
4 1
3 2
2 4
5 3

Sample Output

5 3 2 4 1  
 
拓扑排序
//AOV拓扑排序
#include <iostream>
#include <vector>
#include <queue>
#include <memory.h>
using namespace std; int main()
{
int numTestcases;
cin >> numTestcases; while(numTestcases--)
{
int n, m;
cin >> n >> m;
int inDegree[n + 1]; //入度为0数组
int result[n]; //结果序列
vector<int> tasks[n + 1]; //每一组vector都有该结点的后继结点
memset(inDegree, 0, sizeof(inDegree)); //初始化 for (int i = 0; i < m; ++i)
{
int a, b;
cin >> a >> b;
inDegree[b]++;
tasks[a].push_back(b);
} priority_queue<int, vector<int>, greater<int> > readyTasks;//使用最小优先队列可以自动按照从小到大排序 for (int i = 1; i <= n; ++i)
{//先将所有根结点放进队列中待选
if(inDegree[i] == 0)
readyTasks.push(i);
} int numFinished = 0; while(!readyTasks.empty())
{
int cur = readyTasks.top();
result[numFinished++] = cur;
readyTasks.pop();
vector<int>::iterator it; for(it = tasks[cur].begin(); it != tasks[cur].end();it++)
{
int temp = *it;
inDegree[temp]--;
if(inDegree[temp] == 0)//当前趋结点全部完成时可以开始这个任务
readyTasks.push(temp);
}
} for (int i = 0; i < n; ++i)
{
cout << result[i] << " ";
}
cout << endl;
}
return 0;
}

  

最新文章

  1. 【转】70个经典的 Shell 脚本面试问题
  2. ARM汇编程序结构
  3. PCM(Pulse-code modulation)脉冲编码调制
  4. js 静态私有变量
  5. 省常中模拟 day1
  6. 图片加载完后执行js
  7. com.sun.org.apache.xerces.internal.impl.io.MalformedByteSequenceException: 3 字节的 UTF-8 序列的字节 3 无效。
  8. H5移动前端完美布局之padding
  9. BLOCKED和WAITING的区别
  10. vs2012+qt5.2.0环境搭建/vs2013 + qt5.3.2 环境搭建
  11. Protobuf从安装到配置整理帖 --转
  12. db2迁移至oracle过程中的问题
  13. Hadoop Streaming框架学习2
  14. 极光推送CTO黄鑫:技术人员要建立自己的知识图谱
  15. Jfinal数据库操作语句中占位符的使用
  16. 程序员/PM怎么让项目预估的时间更加准确
  17. websocket 的客户端 websocket-sharp
  18. Educational Codeforces Round 4
  19. 【360】pandas.DataFrame、array、list 之间转换
  20. Win10 快捷键

热门文章

  1. EasyUI DataGrid及Pagination
  2. java常用的环境变量配置
  3. 第一个windows 小游戏 贪吃蛇
  4. DEV 打印gridcontrl
  5. android 源码编译 问题 列表
  6. 学习OpenCV:滤镜系列(15)——羽化(模糊边缘)
  7. C++ 头文件系列(queue)
  8. C++ std::stack
  9. Mybatis学习笔记(二) 之实现数据库的增删改查
  10. jsp-4 用cookie实现记住密码