实验目的与要求

(1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

(2)熟悉PTA平台线上测试环境;

(3)掌握Java语言构造基本程序语法知识(ch1-ch3);

(4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/,使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

实验2-实验3在课后完成

实验2:公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类的nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

实验的代码如下:

import java.util.Scanner;
public class ID1 {
public static void main(String[] args)
{
System.out.println("请输入身份证号18位!");
Scanner scanner=new Scanner(System.in);
String ID=scanner.nextLine();
while(ID.length()!=18)
{
System.out.println("身份证号码必须是18位");
ID=scanner.nextLine();
}
int i=6;
String year = ID.substring(i,i+4);
String month=ID.substring(i+4,i+6);
String day=ID.substring(i+6,i+8);
System.out.println(year+"-"+month+"-"+day);
}
}

实验结果:

2.studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

(1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

(2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

实验代码:

package d;

import java.io.BufferedReader;

import java.io.File;

import java.io.FileReader;

import java.io.IOException;

import java.util.ArrayList;

import java.util.Scanner;

public class D {

private static ArrayList<Student>studentList  = null;

public static void StudentsFromFile(String fileName){

File file = new File(fileName);

BufferedReader reader = null;

try {

reader = new BufferedReader(new FileReader(file));

String tempString = null;

while ((tempString = reader.readLine()) != null) {

String str[] = tempString.split(" ");

if(studentList!= null && str.length > 1) {

//Object studentId;

Student student = new Student();

student.setStudentId(str[0]);

student.setName(str[1]);

studentList.add(student);

}

}

reader.close();

} catch (IOException e) {

e.printStackTrace();

} finally {

if (reader != null) {

try {

reader.close();

} catch (IOException e1) {

}

}

}

}

public static String findStudentIdByName(String name) {

String studentId = null;

for(Student student : studentList) {

if(student.getName().equals(name)) {

studentId = student.getStudentId();

break;

}

}

return studentId;

}

public static String findStudentNameById(String ID) {

String studentName = null;

for(Student student : studentList) {

if(student.getStudentId().equals(ID)) {

studentName = student.getName();

break;

}

}

return studentName;

}

public static void main(String args[]) {

String path = "C:\\Users\\周强\\Documents\\Tencent Files\\1260622021\\FileRecv\\实验三\\studentfile.txt";

studentList = new ArrayList<Student>();

StudentsFromFile(path);

int statu = 1;

System.out.println();

while(statu != 0) {

System.out.println("******************");

System.out.println("1:通过姓名查询学生学号");

System.out.println("2:通过学号查询学生姓名");

System.out.println("0:退出");

System.out.println("******************");

Scanner in = new Scanner(System.in);

statu = in.nextInt();

switch(statu) {

case 1:{                  System.out.println("请输入学生姓名:");

Scanner scanner1 = new Scanner(System.in);

String name = scanner1.nextLine();

String Id = findStudentIdByName(name);

if(Id != null) {

System.out.println("姓名: "+name+" 学号: "+Id);

}else {

System.out.println(""查无此人,请确认");

}

}break;

case 2:{

System.out.println("请输入学生学号:");

Scanner scanner2 = new Scanner(System.in);

String Id = scanner2.nextLine();

String name = findStudentNameById(Id);

if(name != null) {

System.out.println("姓名: "+name+" 学号: "+Id);

}else {

System.out.println("查无此人,请确认");

}

}break;

case 0:

statu = 0; break;

default:

System.out.println("输入错误");

}

}

System.out.println("结束!");

}

}

实验总结:

通过几次实验本人对java这门学科真的不懂,只能尽自己最大努力去完成.对于Scanner类的使用还是不够熟练,由于对于所学知识还没有完全熟练的掌握,导致我对实验三无法正确的输出结果,我会继续查找自己的错误。也会更加深入的学习,不断地改正自己更加需要继续加强对相关知识的学习。

最新文章

  1. vim自动补全插件YouCompleteMe
  2. System.BadImageFormatException: Could not load file or assembly
  3. 自定义 密码是否可见 的EditView 右侧带个小眼睛
  4. Linux命令(15)查看系统版本信息
  5. Node.js上传文件
  6. FTP上传文件夹
  7. Javascript之三种按钮点击事件
  8. Bridging signals ZOJ 3627 POJ1631 HDU1950
  9. linux 远程工具
  10. Android JNI 由C/C++本地代码向Java层传递数据
  11. Android Intent传递对象小结
  12. 5 HBase 常用Shell命令
  13. Ural 1149 - Sinus Dances
  14. 使用ObjectInputStream和ObjectOutputStream注意问题
  15. hive自定义UDF
  16. java中this关键字解析
  17. google sitemap
  18. MySQL--局域网、外网访问MySQL
  19. SpringBoot应用部署到Tomcat中无法启动问题(初识)
  20. numpy中int类型与python中的int

热门文章

  1. java之导入excel
  2. js 计算后样式封装
  3. Linux学习笔记之时间同步the NTP socket is in use, exiting问题
  4. 配置firewalld端口转发
  5. 自制操作系统Antz(4)——进入保护模式 (下) 实现内核并从硬盘载入
  6. rman实验——测试备份压缩
  7. jsp/servlet学习四之jsp初窥
  8. 5th,Python购物车模拟
  9. java常用类介绍
  10. 自我学习成长系列之&lt;&lt;FirstHead设计模式&gt;&gt;