原文链接https://vjudge.net/contest/331993#problem/H

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)


Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.

You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

Sample Input

1
2
3
0

Sample Output

Alice
Alice
Bob
#include <stdio.h>
int main() {
int n;
while(scanf("%d", &n)) {
if(n==) break;
if(n <= )
printf("Alice\n");
else
printf("Bob\n");
}
return ;
}
//1、2个先手赢,3个后手赢,
//现在分析n>=4的情况,先手操作后,环就变成了链,
//如果取走链的中间一个或者两个,变成两个相同的链,
//那么接下来对方怎么取,就再另一串链进行相同操作,这样就可以赢了。
//也就是说00 00、000 000、0000 0000、......这样的左右相同的情况都是先手必败的情况。
//所以一条链时是先手必赢,一个环(n>3)是先手必败的情况。

最新文章

  1. csuoj 1394: Virus Replication
  2. document与window的区别
  3. Centos系统下Lamp环境的快速搭建(超详细,转)
  4. angularJS中-$route路由-$http(ajax)的使用
  5. js获取浏览器的版本代码
  6. SQLserver查询数据库所有字段-表名
  7. R语言和大数据
  8. uCGUI动态内存管理
  9. Docker系列(四)Dockerfile
  10. openstack简易汉化
  11. 【GO】关于GO的浅显总结
  12. 迈向angularjs2系列(7):表单
  13. Servlet--超链接,表单提交,重定向,转发4种情况的路径
  14. UVA - 12186 Another Crisis (树形DP)
  15. Codeforces 438E. The Child and Binary Tree 多项式,FFT
  16. mac下crontab定时任务使用
  17. SQL-5查找所有员工的last_name和first_name以及对应部门编号dept_no,也包括展示没有分配具体部门的员工
  18. Revit API 加载族并生成实例图元
  19. (转)MySQL优化系列
  20. Python实例---CRM管理系统分析180331

热门文章

  1. toj 4353 Estimation(树状数组+二分查找)
  2. js面试相关
  3. 干货!手把手教你使用数据可视化BI软件创建企业变更流程监控大屏
  4. 多线程笔记 - disruptor
  5. CDQ分治笔记+例题
  6. 邓士鹏【MySql大全】
  7. (转)elasticsearch collapse 折叠字段应用
  8. RadioButton改写的开关按钮
  9. udp socket 10054
  10. SpringBoot缓存 --(一)EhCache2.X