Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19841    Accepted Submission(s): 13532

Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and
resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end
of output.
 
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 
Sample Input
10 2 1
20 3 1
0 0 0
 
Sample Output
17
19
 
Source
 
Recommend

We have carefully selected several similar problems for you:  1021 1019 1071 1009 1061

Problem : 1049 ( Climbing Worm )     Judge Status : Accepted

RunId : 21270620    Language : G++    Author : hnustwanghe

Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main(){
int u,n,d,time;
while(scanf("%d %d %d",&n,&u,&d)==3 && (n||u||d)){
time = 1;
while(n-u>0){
time+=2;
n=n-u+d;
}
printf("%d\n",time);
}
}

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace
std; int main(){
int
u,n,d,time;
while(
scanf("%d %d %d",&n,&u,&d)==3 && (n||u||d)){
time = 1;
while(
n-u>0){
time+=2;
n=n-u+d;
}

printf("%d\n",time);
}
}

最新文章

  1. java类加载相关
  2. currentColor-CSS3非常有用的变量
  3. C#中Invoke的用法(转)
  4. Errors running builder &#39;JavaScript Validator&#39; on project
  5. 【nginx】配置文件的优化
  6. Android Google购买PHP服务器端验证(订阅购买和一次性购买)
  7. Git版本控制使用介绍
  8. AndroidManifest.xml中data标签中所有属性的含义
  9. socket 编程基础
  10. Mysql 复制表结构 及其表的内容
  11. perl 正则命名捕获
  12. MySQL常用指令
  13. iOS 调用私有函数安装app 卸载 app
  14. 监听 window.open 打开的窗口关闭并回调
  15. 小程序学习-理解小程序中响应式单位rpx
  16. 获取 MySQL 崩溃时的 core file
  17. Qt打包部署程序自动查找依赖DLL工具windeployqt
  18. python webdriver启动IE浏览器
  19. 使用bat批处理文件备份mysql数据库
  20. Java从零开始学十八(抽象类和接口)

热门文章

  1. 【bzoj1189】[HNOI2007]紧急疏散evacuate
  2. event.stopPropagation()和event.preventDefault(),return false的区别
  3. windows 安装 Mongodb 数据库及操作图形化软件 Robo 3T
  4. 完整的Socket代码
  5. Bug管理工具MantisBT-2.18.0安装教程
  6. TCP与UDP的对比分析
  7. 20175221曾祥杰 实验四《Android程序设计》
  8. jQuery-validate插件初级篇
  9. 屏蔽ffmpeg命令的所有提示
  10. html上传文件