<span style="color:#330099;">/*
A - 广搜 基础
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it? Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
By Grant Yuan
2014.7.13
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<cstdio>
using namespace std;
bool a[100003];
typedef struct{
int num;
int sum;
}dd;
queue<dd>q;
int n,k;
int res;
void slove()
{int m,count;
int x;
dd init;
while(!q.empty()){ if(q.front().num==n)
{ res=q.front().sum;
break;
} m=q.front().num;
count=q.front().sum;
x=m-1;
if(a[x]==0)
{ init.num=x;
init.sum=count+1;
q.push(init);
a[x]=1;
} x=m+1;
if(a[x]==0)
{
init.num=x;
init.sum=count+1;
q.push(init);
a[x]=1; } if(m%2==0){
x=m/2;
if(a[x]==0)
{
init.num=x;
init.sum=count+1;
q.push(init);
a[x]=1;
}}
q.pop();}
} int main()
{
scanf("%d%d",&n,&k);
memset(a,0,sizeof(a));
dd init;
init.num=k;
init.sum=0;
a[k]=1;
q.push(init);
slove();
cout<<res<<endl;
return 0;
} </span>

最新文章

  1. Ubuntu 14.04安装Cinnamon桌面环境
  2. Java多线程Thread
  3. Diophantus of Alexandria[HDU1299]
  4. SAP web 开发 (第二篇 bsp 开发 mvc模式 Part1 )
  5. git中进入带有空格的目录下的解决办法
  6. hdu1251(字典树)
  7. Java之美[从菜鸟到高手演练]之JDK动态代理的实现及原理
  8. CMakeLists实战解读--YouCompleteMe
  9. 如何在CentOS 5.x 中安装Windows Azure Linux Agent (WALA)
  10. PCanywhere/teamviewer/RDP/ultraVNC/tigerVNC/realVNC/Xmanager
  11. memcached原理全面剖析
  12. Exception Handling in ASP.NET Web API
  13. Archlinux无线联网教程
  14. Tomcat 优化方案 和 配置详解(转)
  15. JAVA进阶17
  16. shell编程 之 传递参数到脚本里
  17. Leaflet_扩展Leaflet:类(2017-10-26)
  18. 20165215 2017-2018-2 《Java程序设计》第7周学习总结
  19. X240 Ubuntu18.04安装流水帐
  20. C++静态成员变量和静态成员函数

热门文章

  1. jquery eq()选择器 语法
  2. Cisco基础(三):HSRP配置、三层交换配置HSRP、STP的配置、三层交换配置STP
  3. Oracle数据库表空间查看和更改
  4. mysqli使用localhost问题
  5. @WebService这个标签的作用是什么
  6. pytorch之Resize()函数
  7. js2flowchart
  8. python读取文件乱码
  9. spir 合并单元格
  10. 那些年我们经历的BT面试题