Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16565 Accepted Submission(s): 6087

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

2

4

6

#include <iostream>
#include <set>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int MAX=101000;
typedef pair<int ,double >pr;
typedef long long LL;
double Dp[11000];
pr a[110];
double s;
int n,sum;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%lf %d",&s,&n);
sum=0;
for(int i=0;i<n;i++)
{
scanf("%d %lf",&a[i].first,&a[i].second);
sum+=a[i].first;
}
memset(Dp,0,sizeof(Dp));
Dp[0]=1;
for(int i=0;i<n;i++)//将金钱作为重量概率作为价格进行01背包
{
for(int j=sum;j>=a[i].first;j--)
{
Dp[j]=max(Dp[j],Dp[j-a[i].first]*(1-a[i].second));
}
}
int ans=0;
s=1-s;
for(int i=sum;i>0;i--)//要求是被抓住的概率小于s,就是不被抓住的概率大于(1-s)
{
if(s<Dp[i])
{
ans=i;
break;
}
}
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. .NET跨平台之旅:在Linux上将ASP.NET 5运行日志写入文件
  2. STM32 assert_param
  3. ubuntu使用 服务
  4. MVC3下的layout页面
  5. UVa 340 Master-Mind Hints (优化查找&amp;复制数组)
  6. (大数据工程师学习路径)第四步 SQL基础课程----约束
  7. POJ1719- Shooting Contest(二分图最大匹配)
  8. PL/SQL配置大小写转换等快捷键
  9. Jquery qTip2实现多种提示效果,支持ajax,以及多种样式
  10. C++11 标准新特性: 右值引用与转移语义
  11. C语言一个双向链表的实现
  12. Ext.Net 1.x_Ext.Net.GridPanel 事件
  13. java数组的for遍历
  14. Jenkins-job之间依赖关系配置
  15. java基础题刷题中的知识点复习
  16. ubuntu16.04下vim的安装与配置
  17. Fuel 30 分钟快速安装OpenStack
  18. poi workbook转成流
  19. Java——线程池
  20. Mockplus 3.2前瞻,五大特色功能让你惊喜!

热门文章

  1. PAT 解题报告 1009. Product of Polynomials (25)
  2. https协议
  3. IDEA文件编码修改
  4. 实验十三_编写、应用中断例程_2 &amp; 总结
  5. 一步一步学习Swift之(一):关于swift与开发环境配置
  6. 锋利的jQuery
  7. SQL 简单查询语句 select
  8. zjuoj 3603 Draw Something Cheat
  9. C#写好的类库dll怎么在别人调用的时候也能看到注释?
  10. [转]IP动态切换脚本