Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you’ll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?

Input There will be at most 10 test cases, each containing a single line with an integer n (1 ≤ n ≤ 100). The input terminates with n = 0, which should not be processed.

Output For each test case, print the number of full bottles of coco-cola that you can drink. Spoiler Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2 empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and finally return this empty bottle to the shop!

Sample Input 3 10 81 0

Sample Output 1 5 40

不懂算法也会做这题,看了题目,在稿纸上写了几步结果,发现它很有规律,

那就是n=1时,f(n)=0;n>1时,f(2)=1,f(3)=1,f(4)=2,···,f(81)=40,···,所以f(n)=n/2;然后就完事了。

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int t=0,n;
while(t<10)
{
scanf("%d",&n);
if(n==0)
break;
if(n==1)
printf("0\n");
if(n==2||n>2)
printf("%d\n",n/2);
t++;
}
return 0; }

最新文章

  1. [LeetCode] Product of Array Except Self 除本身之外的数组之积
  2. YARN DistributedShell源码分析与修改
  3. js数据类型判断和数组判断
  4. iOS - MPMoviePlayer 视频播放
  5. Html特殊字符转义处理
  6. nginx方面的书籍资料链接
  7. jquery + ajax调用后台方法
  8. Effective C++:条款37:绝不又一次定义继承而来的缺省參数值
  9. NSArray的排序问题
  10. 再起航,我的学习笔记之JavaScript设计模式04
  11. Spring第七篇【Spring的JDBC模块】
  12. Hibernate学习---基本介绍+作用+配置
  13. c# 复制dataset中table结构跟数据
  14. Android简易实战教程--第四十二话《Spinner下拉级联效果》
  15. layui 表格内容显示更改
  16. Poj2688cleaningrobot
  17. java后端面试
  18. kafka在zookeeper上的节点信息和查看方式
  19. EL语言表达式 (一)【语法和特点】
  20. iptables禁止别人,允许自己

热门文章

  1. final简介
  2. Python项目实战
  3. VC++多工程项目
  4. GreenPlum简单性能测试与分析
  5. js获取多个标签元素的内容,并根据元素的内容修改标签的属性
  6. pvresize - Unix, Linux Command
  7. 从Oracle迁移到Mysql之前必须知道的50件事
  8. 笔记8:winfrom连接数据库DBHelp
  9. Spring源码学习-PropertyPlaceholderHelper
  10. Could not find artifact com.sun:tools:jar:1.5.0