Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1889    Accepted Submission(s): 639

Problem Description
Queues
and Priority Queues are data structures which are known to most
computer scientists. The Team Queue, however, is not so well known,
though it occurs often in everyday life. At lunch time the queue in
front of the Mensa is a team queue, for example.
In a team queue
each element belongs to a team. If an element enters the queue, it first
searches the queue from head to tail to check if some of its teammates
(elements of the same team) are already in the queue. If yes, it enters
the queue right behind them. If not, it enters the queue at the tail and
becomes the new last element (bad luck). Dequeuing is done like in
normal queues: elements are processed from head to tail in the order
they appear in the team queue.

Your task is to write a program that simulates such a team queue.

 
Input
The
input will contain one or more test cases. Each test case begins with
the number of teams t (1<=t<=1000). Then t team descriptions
follow, each one consisting of the number of elements belonging to the
team and the elements themselves. Elements are integers in the range 0 -
999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

 
Output
For
each test case, first print a line saying "Scenario #k", where k is the
number of the test case. Then, for each DEQUEUE command, print the
element which is dequeued on a single line. Print a blank line after
each test case, even after the last one.
 
Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
 
Sample Output
Scenario #1
101
102
103
201
202
203
 
Scenario #2
259001
259002
259003
259004
259005
260001
 
Source
 
 
 
解析:运用map将人按编号映射到所属队伍编号,用一个队列数组q1存储各个队列里人的编号,用一个队列q2存储各个队伍的编号。
 
 
 
#include <bits/stdc++.h>
using namespace std; map<int, int> mp;
char op[10];
int t, n, p, cn = 0; int main()
{
while(scanf("%d", &t), t){
mp.clear();
printf("Scenario #%d\n", ++cn);
for(int i = 0; i < t; ++i){
scanf("%d", &n);
while(n--){
scanf("%d", &p);
mp[p] = i;
}
}
queue<int> q1[1005];
queue<int> q2;
while(scanf("%s", op), op[0] != 'S'){
if(op[0] == 'E'){
scanf("%d", &p);
int id = mp[p];
if(q1[id].empty())
q2.push(id);
q1[id].push(p);
}
else if(op[0] == 'D'){
int id = q2.front();
printf("%d\n", q1[id].front());
q1[id].pop();
if(q1[id].empty())
q2.pop();
}
}
printf("\n");
}
return 0;
}

  

最新文章

  1. OpenLayers控制瓦片的绽放级别
  2. C# 中 async/await 调用传统 Begin/End 异步方法
  3. 李洪强漫谈iOS开发[C语言-042]-简单计算器
  4. 【转】HashMap的工作原理
  5. hbase 取多个版本数据
  6. tomcat源码阅读
  7. scons构建自己的一个简单的程序
  8. hbase权威指南学习笔记--架构--存储
  9. nopCommerce 3.9 大波浪系列 之 路由扩展 [多语言Seo的实现]
  10. 设计模式二: 工厂方法(Factory Method)
  11. 安装vue-cli-service和webpack
  12. windows下配置下burpsuite的小方法。
  13. 2、原生jdbc的dao模式
  14. java List 根据属性排序
  15. 简单JNI使用demo
  16. android 很多应用中用到的 listView + viewPager
  17. 【转载】经典.net面试题目【为了笔试。。。。。】
  18. Django本地开发,debug模式引用静态文件
  19. mysql和redis加入到windows服务
  20. Date类为什么设计为可变的,而不是像String一样?

热门文章

  1. HDU 1227 Fast Food (DP)
  2. 黑马程序员-C#学习笔记
  3. switch… case 语句的用法
  4. LR_问题_运行场景时提示scripts you are running in invalid
  5. Nim语言:Pascal的语法,Python的缩进
  6. PowerDesigner中转换物理模型时的命名转换
  7. 英文论文写作之讨论与结论Discussion and Conclusion
  8. Android开发之android:process=&quot;:remote&quot;
  9. tomcat web.xml配置
  10. 【转载】Java垃圾回收内存清理相关(虚拟机书第三章),GC日志的理解,CPU时间、墙钟时间的介绍