Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci. 



However, the forest will make the following change sometimes: 

1. Two rows of forest exchange. 

2. Two columns of forest exchange. 

Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits. 



Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
Input
The input consists of multiple test cases. 



The first line has one integer W. Indicates the case number.(1<=W<=5)



For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)



The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)



The next line has one integer T. (0<=T<=10^5)

The next T lines, each line has three integers Q, A, B. 

If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange. 

If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange. 

If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B). 

(Ensure that all given A, B are legal. )
 
Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.



In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 
Sample Input
1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2
 
Sample Output
Case #1:
1
2
1
Hint
No two fruits at the same location.
 


题目中的N, M 太大   所以不能直接记录
用两个map表示,row[i] = j 表示 i行换到了j行,反之同理  col表示列 
另外一个map   maze记录<i, j>这个位置的值
每次查询前先将正确的行列在row,col中映射。输出答案就可以

#include <cstdio>
#include <ctime>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <string>
#include <set>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#include <iostream>
#include <algorithm>
#include <bitset>
#include <fstream>
using namespace std;
//LOOP
#define FF(i, a, b) for(int i = (a); i < (b); ++i)
#define FE(i, a, b) for(int i = (a); i <= (b); ++i)
#define FED(i, b, a) for(int i = (b); i>= (a); --i)
#define REP(i, N) for(int i = 0; i < (N); ++i)
#define CLR(A,value) memset(A,value,sizeof(A))
//OTHER
#define PB push_back
//INPUT
#define RI(n) scanf("%d", &n)
#define RII(n, m) scanf("%d%d", &n, &m)
#define RIII(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define RIV(n, m, k, p) scanf("%d%d%d%d", &n, &m, &k, &p)
#define RV(n, m, k, p, q) scanf("%d%d%d%d%d", &n, &m, &k, &p, &q)
#define RS(s) scanf("%s", s)
//OUTPUT #define sqr(x) (x) * (x)
typedef long long LL;
typedef unsigned long long ULL;
typedef vector <int> VI;
const double eps = 1e-9;
const int MOD = 1000000007;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int maxn = 100010; map<int, int>col, row;
map<pair<int, int>, int>maze;
int main()
{
//freopen("0.txt", "r", stdin);
int T, n, m, k, a, t;
RI(T);
FE(kase, 1, T)
{
row.clear(), col.clear(), maze.clear();
printf("Case #%d:\n", kase);
RIII(n, m, k);
int x, y, c, Q;
REP(i, k)
{
RIII(x, y, c);
maze[make_pair(x, y)] = c;
}
int tx, ty;
RI(Q);
while (Q--)
{
RIII(c, x, y);
tx = x, ty = y;
if (c == 2)
{
if (col.count(x)) tx = col[x];
if (col.count(y)) ty = col[y];
col[x] = ty;
col[y] = tx;
}
else if (c == 1)
{
if (row.count(x)) tx = row[x];
if (row.count(y)) ty = row[y];
row[x] = ty;
row[y] = tx;
}
else
{
if (row.count(x))
x = row[x];
if (col.count(y))
y = col[y];
a = 0;
if (maze.count(make_pair(x, y)))
a = maze[make_pair(x, y)];
printf("%d\n", a);
}
}
}
return 0;
}

最新文章

  1. 20个非常棒的jQuery倒计时脚本
  2. JavaScript DOM编程艺术读书笔记(三)
  3. IOS中Json解析的四种方法
  4. 每天checklist所用到的T-CODE
  5. Shell编程基础教程2--变量和运算符
  6. 夺命雷公狗mongodb之----mongodb---2---常用命令和技巧
  7. Java--&gt;实现群聊功能(C/S模式--TCP协议)
  8. Codeforces Round #214 (Div. 2) c题(dp)
  9. Innodb加载数据字典 &amp;&amp; flush tables
  10. cocos2d-x android项目引用so库编译
  11. c# gzip解压缩
  12. [Apache Spark源代码阅读]天堂之门——SparkContext解析
  13. php 启动过程 - reqeust RSHUTDOWN 过程
  14. Python3.6下scrapy框架的安装
  15. android - TextView单行显示...或者文字左右滚动(走马灯效果)
  16. uiautomatorviewer 查看元素报错: Error taking device screenshot: null 原因
  17. Codeforces 1012D AB-Strings 贪心
  18. Oralce sql (+) 补充
  19. webstorm 2018.10月 License server 最新激活码
  20. ES之五:ElasticSearch聚合

热门文章

  1. bacula快速部署
  2. fork 和 exec
  3. 第五章:C++程序的结构
  4. python_正则_re模块
  5. Nginx安装及基本配置
  6. CDOJ 1218 Pick The Sticks
  7. Flask---ajax(jquery)交互
  8. 倍增法求LCA
  9. left join 与left outer join的区别
  10. hdu 1689 求奇环bfs关键是层次图