Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1123 Accepted Submission(s): 595

Problem Description

Let’s play a card game called Gap.

You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.

Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: “11” to the top row, “21” to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.

At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of “42” is “43”, and “27” has no successor.

In the above layout, you can move “43” to the gap at the right of “42”, or “36” to the gap at the right of “35”. If you move “43”, a new gap is generated to the right of “16”. You cannot move any card to the right of a card of value 7, nor to the right of a gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.

Your task is to find the minimum number of moves to reach the goal layout.

Input

The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.

Output

For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce “-1”.

Sample Input

4

12 13 14 15 16 17 21

22 23 24 25 26 27 31

32 33 34 35 36 37 41

42 43 44 45 46 47 11

26 31 13 44 21 24 42

17 45 23 25 41 36 11

46 34 14 12 37 32 47

16 43 27 35 22 33 15

17 12 16 13 15 14 11

27 22 26 23 25 24 21

37 32 36 33 35 34 31

47 42 46 43 45 44 41

27 14 22 35 32 46 33

13 17 36 24 44 21 15

43 16 45 47 23 11 26

25 37 41 34 42 12 31

Sample Output

0

33

60

-1

【题目链接】:http://acm.hdu.edu.cn/showproblem.php?pid=1067

【题解】



搜索题。

这题的判重方法和八数码类似;

把整张4*8的图降成一维的图;

判重的时候转换成一个字符串判重就好;

在bfs的队列里面

记录

{

———-4*7个数码在哪一个位置;

———-4个空格的位置;

———-当前的步数;

———-这张图用一维字符串的表示;

}

在扩展的时候

枚举4个空格.

看看4个空格左边是什么;

如果是0或者尾数为7就跳过;

否则找到比它大1的数码(我们有记录)的位置;

(二维的坐标和一维的坐标可以通过(x-1)*8+y来转换)

然后调换字符串中两个数目;

更改那个被调换的数目的位置(不要忘了!)

更改空格的位置;

修改当前步数;

入队。

如此循环一下就OK了.

判重用map



【完整代码】

#include <bits/stdc++.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
#define rep1(i,a,b) for (int i = a;i <= b;i++)
#define rep2(i,a,b) for (int i = a;i >= b;i--)
#define mp make_pair
#define pb push_back
#define fi first
#define se second
#define rei(x) scanf("%d",&x)
#define rel(x) scanf("%I64d",&x) typedef pair<int,int> pii;
typedef pair<LL,LL> pll; const int dx[9] = {0,1,-1,0,0,-1,-1,1,1};
const int dy[9] = {0,0,0,-1,1,-1,1,-1,1};
const int goal[32] = {11,12,13,14,15,16,17,0,21,22,23,24,25,26,27,0,31,32,33,34,35,36,37,0,41,42,43,44,45,46,47,0};
const double pi = acos(-1.0);
const int MAXN = 110; struct abc
{
pii po[50],kong[5];
int dis;
string s;
}; char chushi[5][10];
string sgoal,ts;
map <string,int> dic;
queue <abc> dl; bool bfs()
{
dic.clear();
while (!dl.empty()) dl.pop();
abc pre;
pre.dis = 0;pre.s = " ";
int num = 0;
rep1(i,1,4)
{
rep1(j,1,8)
{
pre.s+=chushi[i][j];
if (chushi[i][j]==0)
pre.kong[++num] = {i,j};
else
pre.po[int(chushi[i][j])] = {i,j};
}
}
dic[pre.s] = 1;
if (dic[sgoal])
{
puts("0");
return true;
}
dl.push(pre);
while (!dl.empty())
{
abc temp = dl.front();dl.pop();
for (int i = 1;i <= 4;i++)
{
abc t = temp;
int tx = t.kong[i].fi,ty = t.kong[i].se;
int sz = (tx-1)*8+ty;
int judge = t.s[sz-1];
if (judge==0 || judge%10==7) continue;
int tx1 = t.po[judge+1].fi,ty1 = t.po[judge+1].se;
int sz1 = (tx1-1)*8+ty1;
swap(t.s[sz],t.s[sz1]);
if (!dic[t.s])
{
dic[t.s] = 1;
t.kong[i] = {tx1,ty1};
t.po[judge+1] = {tx,ty};
t.dis++;
if (dic[sgoal])
{
printf("%d\n",t.dis);
return true;
}
dl.push(t);
}
}
}
return false;
} int main()
{
//freopen("F:\\rush.txt","r",stdin);
sgoal = " ";
for (int i = 0;i <= 31;i++)
sgoal+=goal[i];
int T;
rei(T);
while (T--)
{
memset(chushi,0,sizeof chushi);
rep1(i,1,4)
rep1(j,2,8)
{
int x;
rei(x);
chushi[i][j] = x;
if (x%10==1)
swap(chushi[x/10][1],chushi[i][j]);
}
if (!bfs())
puts("-1");
}
return 0;
}

最新文章

  1. 一起阅读《Java多线程编程核心技术》
  2. Node.js开发者最常范的10个错误
  3. myscroll
  4. 设置westorm自动代码提示
  5. mysqlsla 分析mysql慢查询日志
  6. Google Play市场考察报告
  7. R1:创建Libevent库
  8. phonegap开发app中踩过的那些坑
  9. java.lang.OutOfMemoryError: PermGen space 解决方案
  10. Android定位功能(二)
  11. 去除右键的opendgl
  12. 【JAVAWEB学习笔记】09_MySQL多表&amp;JDBC(包含MySQL数据库思维导图)
  13. 洛谷 P3928 Sequence
  14. [译]Dapper教程
  15. J.U.C CAS
  16. DML 触发器2
  17. redis缓存的应用详解
  18. UWP 使用Telerik Chart控件
  19. LeetCode题型分类及索引
  20. 使用 Nexus Repository Manager 搭建私有docker仓库

热门文章

  1. 《开源公开课分享》:Java开源框架案例分享
  2. Android RecyclerView And CardView
  3. HDU 3131 One…Two…Five! (暴力搜索)
  4. 修改chrome的安装目录(默认的竟然安装在documents and settings目录,google真不厚道)
  5. Apache/Tomcat/JBOSS/Nginx区别(转)
  6. BlobTracker
  7. Garbage Collection Optimization for High-Throughput and Low-Latency Java Applications--转载
  8. AbstractQueuedSynchronizer的介绍和原理分析
  9. POJ 3669 Meteor Shower BFS 水~
  10. 【AtCoder Beginner Contest 074 A】Bichrome Cells