Error Correction
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6014   Accepted: 3886

Description

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:

1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 

Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified
as corrupt. 


Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix.
Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed.
Otherwise, print "Corrupt".

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

Source

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <iostream>
using namespace std;
int main()
{
int a[105][105],b[105],c[105],i,j,n;
while(cin >> n,n)
{
for(i = 0; i<n; i++)
for(j = 0; j<n; j++)
cin >> a[i][j];
for(i = 0; i<n; i++)
{
b[i] = 0;
for(j = 0; j<n; j++)
b[i]+=a[i][j];
}
for(i = 0; i<n; i++)
{
c[i] = 0;
for(j = 0; j<n; j++)
c[i]+=a[j][i];
}
int sum1=0,sum2 = 0,flag1,flag2;
for(i = 0; i<n; i++)
if(b[i]%2)
sum1++,flag1 = i;
for(i = 0; i<n; i++)
if(c[i]%2) sum2++,flag2 = i;
if(sum1 > 1 || sum2>1)cout << "Corrupt" << endl;
else if(!sum1 && !sum2)cout << "OK" << endl;
else cout << "Change bit (" << flag1+1 << "," << flag2+1 << ")" << endl;
}
return 0;
}

最新文章

  1. svn 版本库的创建和配置
  2. 使用动态类型dynamic让你的省了很多临时类
  3. Java设计模式-组合模式(Composite)
  4. delphi读取excel
  5. WPF 关于XDocument(xml) 的部分操作记录
  6. http协议请求规则与dotNet的解析
  7. activity的生命周期【转】
  8. MySQL主从同步校验与重新同步
  9. 全面解释java中StringBuilder、StringBuffer、String类之间的关系
  10. Unable to open debugger port (127.0.0.1:51554): java.net.SocketException &quot;socket closed&quot;
  11. [.NET] 《Effective C#》快速笔记(一)- C# 语言习惯
  12. TerraGate软件安装后,不能启动的解决办法
  13. 【洛谷P1073】最优贸易
  14. C#中将string转换为float
  15. Linux命令学习之路——档案拷贝:cp
  16. 2017 icpc 沈阳 G - Infinite Fraction Path
  17. PCL滤波介绍(1)
  18. 关于SpringMVC Json使用
  19. 常用maven命令总结
  20. 【第三十章】 elk(1) - 第一种架构(最简架构)

热门文章

  1. 笔试算法题(13):反转链表 &amp; 左旋转字符串
  2. VIM命令大全(图+文)
  3. PHP—通过HTML网页请求,PHP页面显示源码不能解析
  4. lnmp -memcached使用
  5. C#NumberFormatInfo类
  6. vim使用学习
  7. python 安装模块 更新模块
  8. UVALive 6430 (水dp)
  9. [K/3Cloud] 创建一个单据转换插件
  10. next_permitation