Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1729    Accepted Submission(s): 661
Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest
of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.


 
Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line
consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.

The last test case is followed by a line containing two zeros, which means the end of the input.
 
Output
Output the sum of the value of the edges of the maximum pesudoforest.
 
Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0
 
Sample Output
3
5
 
Source

题意:这题的题意折腾了好久才懂,開始以为是求最多有一个环的最大联通分量,然后WA了,后来才知道是求多个分量的最大和。每一个分量最多有一个环。

题解:边权从大到小排序,对于每条边的起点终点a、b有三种情况:

1、a、b分属两个环。此时a、b不能连接;

2、a、b当中一个属于环。此时将还有一个连过去或者两个都不在环中,此时随意连;

3、a、b在同一集合。但该集合无环。此时连接a、b并生成环。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 10002
#define maxm 100002
using std::sort; struct Node{
int u, v, cost;
} E[maxm];
int pre[maxn];
bool Ring[maxn]; bool cmp(Node a, Node b){
return a.cost > b.cost;
} int ufind(int k)
{
int a = k, b;
while(pre[k] != -1) k = pre[k];
while(a != k){
b = pre[a];
pre[a] = k;
a = b;
}
return k;
} int greedy(int n, int m)
{
int ans = 0, i, u, v;
for(i = 0; i < m; ++i){
u = E[i].u; v = E[i].v;
u = ufind(u); v = ufind(v);
if(Ring[u] && Ring[v]) continue;
if(u != v){
if(Ring[v]) pre[u] = v;
else pre[v] = u;
ans += E[i].cost;
}else if(Ring[v] == false){
Ring[v] = true;
ans += E[i].cost;
}
}
return ans;
} int main()
{
int n, m, a, b, c, i;
while(scanf("%d%d", &n, &m), n||m){
memset(pre, -1, sizeof(pre));
memset(Ring, 0, sizeof(Ring));
for(i = 0; i < m; ++i)
scanf("%d%d%d", &E[i].u, &E[i].v, &E[i].cost);
sort(E, E + m, cmp);
printf("%d\n", greedy(n, m));
}
return 0;
}

最新文章

  1. Oracle数据库的创建以及远程连接(PL/SQL Developer远程连接数据库)
  2. pythonchallenge之C++学习篇-00
  3. Bugtags 与其它产品的区别
  4. 【转】CentOS 6.3 X64自动安装OpenERP 7.0脚本
  5. 无法嵌入互操作类型“ESRI.ArcGIS.Display.SimpleFillSymbolClass”。请改用适用的接口。
  6. Java [Leetcode 228]Summary Ranges
  7. NetAnalyzer笔记 之 一. 开篇语
  8. itextSharp 使用模板(PdfTemplate)不规则分栏(ColumnText)
  9. 【Eclipse高速发展-文章插件】google V8,对于调试Nodejs
  10. Java:构造器,构造代码块,静态代码块的执行顺序
  11. 谨慎修改Python的类属性
  12. PAT1083:List Grades
  13. MindFusion 中节点关键路径的遍历
  14. 【loj6142】「2017 山东三轮集训 Day6」A 结论题+Lucas定理
  15. Java - &quot;JUC&quot; ReentrantLock获取锁
  16. mongodb常用的查询命令例子
  17. Beta阶段基于NABCD评论作品
  18. Docker 安装使用
  19. UNITY把3D模型显示在UI层级上的思路
  20. CodeForces 380C Sereja and Brackets(扫描线+树状数组)

热门文章

  1. spring封装的RabbitMQ
  2. Unexpected token d in JSON at position 669 while parsing near &#39;...ct-mode&quot;:&quot;^6.0.2&quot;}
  3. copy on write
  4. vue-cli webpack 快速搭建项目
  5. MySQL与MyBatis中的查询记录
  6. jQuery调用WCF 说明
  7. Jmeter-接口测试实例讲解
  8. java程序验证用户名密码和验证码登录的小例子
  9. HDU 5458 Stability
  10. pdf &amp; background