Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1870    Accepted Submission(s): 916

Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group,
the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 
Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities
of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 
Output
For each test,output the number of groups.
 
Sample Input
2
4 2
3 1 2 4
10 5
0 3 4 5 2 1 6 7 8 9
 
Sample Output
5
28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 
Author
FZUACM
 
Source
 
Recommend
We have carefully selected several similar problems for you:  5315 5314 5313 

pid=5312" target="_blank">5312 

pid=5311" target="_blank">5311 

 题目大意:输入n,k,问n个数的序列。有多少个区间,最大值减最小值小于k
暴力找区间超时一次
ac代码,跑了1000ms
#include<stdio.h>
#include<string.h>
#include<math.h>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a>b?b:a)
int n;
__int64 m;
__int64 a[100010];
__int64 maxv[100010][20],minv[100010][20];
void init()
{
int i,j,k;
for(i=1;i<=n;i++)
{
minv[i][0]=a[i];
maxv[i][0]=a[i];
}
for(j=1;(1<<j)<=n;j++)
{
for(k=0;k+(1<<j)-1<=n;k++)
{
minv[k][j]=min(minv[k][j-1],minv[k+(1<<(j-1))][j-1]);
maxv[k][j]=max(maxv[k][j-1],maxv[k+(1<<(j-1))][j-1]);
}
}
}
__int64 q_max(int l,int r)
{
int k=(int)(log((double)(r-l+1))/log(2.0));
return max(maxv[l][k],maxv[r-(1<<k)+1][k]);
}
__int64 q_min(int l,int r)
{
int k=(int)(log((double)(r-l+1))/log(2.0));
return min(minv[l][k],minv[r-(1<<k)+1][k]);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%I64d",&n,&m);
int i,j,k;
for(i=1;i<=n;i++)
{
scanf("%I64d",&a[i]);
}
init();
__int64 ans=0;
int p=1;
/*for(i=1;i<=n;i++)//暴力超时
{
for(j=i;j<=n;j++)
{
if(q_max(i,j)-q_min(i,j)<m)
ans++;
}
}*/
for(i=1;i<=n;i++)
{
while(q_max(p,i)-q_min(p,i)>=m&&p<i)
{
p++;
}
ans+=i-p+1;
}
printf("%I64d\n",ans);
}
}

网上看到用deque做的,跑了577ms,收藏一下,http://www.bubuko.com/infodetail-987302.html

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std ;
#define LL __int64
deque <LL> deq1 , deq2 ;
//单调队列,deq1最大值,deq2最小值
LL a[100010] ;
int main() {
int t , n , i , j ;
LL k , ans ;
scanf("%d", &t) ;
while( t-- ) {
scanf("%d %I64d", &n, &k) ;
for(i = 0 ; i < n ; i++)
scanf("%I64d", &a[i]) ;
if(k == 0) {
printf("0\n") ;
continue ;
}
while( !deq1.empty() ) deq1.pop_back() ;
while( !deq2.empty() ) deq2.pop_back() ;
for(i = 0 , j = 0 , ans = 0; i < n ; i++) {//i在前。j在后
while( !deq1.empty() && deq1.back() < a[i] ) deq1.pop_back() ;
deq1.push_back(a[i]) ;
while( !deq2.empty() && deq2.back() > a[i] ) deq2.pop_back() ;
deq2.push_back(a[i]) ;
while( !deq1.empty() && !deq2.empty() && deq1.front() - deq2.front() >= k ) {
ans += (i-j) ;
//printf("%d %d,%I64d %I64d\n", i , j, deq1.front() , deq2.front() ) ;
if( deq1.front() == a[j] ) deq1.pop_front() ;
if( deq2.front() == a[j] ) deq2.pop_front() ;
j++ ;
}
}
while( j < n ) {
ans += (i-j) ;
j++ ;
}
printf("%I64d\n", ans) ;
}
return 0 ;
}

最新文章

  1. matlab GUI封装exe文件
  2. 编辑 Ext 表格(一)——— 动态添加删除行列
  3. oracle之集合操作函数---minus、union、intersect
  4. Request.ServerVariables
  5. web框架--flask
  6. 苹果系统里面部署ASP.NET
  7. JVM&lt;一&gt;----------运行时数据区域
  8. RANSAC随机一致性采样算法学习体会
  9. Oracle角色
  10. .net 开源相关
  11. 【html】【1】html的简单结构
  12. 通过try、except和else的使用来使Python程序更加“强壮”
  13. VS 制作安装包小窥
  14. ac automaton 专题
  15. SharePoint 2013 配置启用搜索服务
  16. JPA实体类注解、springboot测试类、lombok的使用
  17. openresty+websocket+redis simple chat
  18. expprt与环境变量
  19. console控制台的小问题
  20. nginx或者squid正向代理实现受限网站的访问

热门文章

  1. mongodb数据库命令
  2. 2星|《约见投资人》:A股上市公司软文集
  3. Jmeter之计数器
  4. 梦想CAD控件 2019.01.20更新
  5. share——Alpha版(内部测试版)发布
  6. Linux学习笔记(二) 文件管理
  7. 基于 Ubuntu 搭建 FTP 文件服务
  8. FZU 1492 地震预测(模拟链表的应用)(Java实现)
  9. CKplayer:视频推荐和分享插件设置
  10. JavaScript学习总结(12)——2016 年 7 个顶级 JavaScript 框架