1.gcd

递归实现

int gcd(int i,int j)
{
if(j==0) return i;
else return gcd(j,i%j);
}

2、lcm

int gcd(int i,int j)
{
if(j==0) return i;
else return gcd(j,i%j);
}

int lcm(int i ,int j)

{

return i*j/gcd(i*j);

}

3.

E - Wolf and Rabbit

兔子坑问题

There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
Sample Input

2
1 2
2 2

Sample Output

NO
YES
题目意思:狼抓兔子,输入m,n,狼能进入每相距为m的洞,洞的编号为0——n-1,如果狼每个洞都能进入,兔子就会被吃,问:兔子能不能存活?
如果狼每一个洞都能进去,兔子才会必死无疑,即在剔除m为1,这种特殊情况后,m,n,不能存在倍数关系,那么狼便能进入每一个洞,即他们的最大公约数为1.
#include <iostream>
using namespace std;
int gcd(int i,int j)
{
if(j==) return i;
else return gcd(j,i%j);
}
int main()
{
long long t,m,n;
cin>>t;
while(t--)
{
cin>>m>>n;
if(gcd(m,n)==)
cout<<"NO"<<endl;
else cout<<"YES"<<endl;
}
}
												

最新文章

  1. ajax的两种方式
  2. 数据库的日志数据库(_log.ldf)文件太大,如何压缩
  3. AngularJS从构建项目开始
  4. 为什么要用Java泛型
  5. 团体程序设计天梯赛-练习集L1-003. 个位数统计
  6. HDOJ-ACM1012(JAVA)
  7. 10.21_Nutz批量插入顺序,POI,wiki持续关注,POI,SSH,数据库优先
  8. 转载 VC 2010下安装OpenCV2.4.4
  9. vb6源码后台点击任意窗口指定坐标XY位置,支持FLASH和一般的游戏
  10. 改变Edit的光标(使用CreateCaret,ShowCaret和LoadBitmap三个API函数)
  11. Box布局
  12. request拿各种东西
  13. Spark性能调优之资源分配
  14. 当freemarker中EL表达式的值为空时出现异常的解决方法
  15. Django模板的加深
  16. Jenkins 构建 coding项目,插件
  17. 关于命名空间的using声明
  18. vsftpd被动模式配置
  19. addClass()使用方法
  20. ubuntu下安装memcached和PHP的memcache扩展

热门文章

  1. poj--2549--Sumsets(二分查找)
  2. python 3.x 学习笔记10 (析构函数and继承)
  3. 如何去掉边框及input的兼容问题?
  4. Jquery 设置class 和 div CSS
  5. solarwinds之数据库
  6. http_build_query 字符串拼接
  7. n行m列矩阵顺时针填写1~n*m
  8. Mojo C++ Bindings API
  9. Vue-cli 3.0 构建项目
  10. TP5防sql注入、防xss攻击