题目

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N​1​​ a​N​1​​ ​​ N​2​​ a​N​2​​ ​​ ... N​K​​ a​N​K​​ ​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N

​K​​ <⋯<N​2​​ <N​1​​ ≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目解读

给出两个多项式,每个输入格式是 非零项个数 指数1 系数1 指数2 系数2

让计算两多项式的和,并按照指定格式输出 非零项个数 指数1 系数1 指数2 系数2

要求顺序是指数从高到低

思路解析

  • 可以用一个结构体来保存每一项的指数和系数,然后在第二次输入时根据去找到相应的那一项,对其系数进行修改。
  • 这样做既浪费存储空间也浪费时间,但一般都能想到,更好的做法是,用一个数组来取代整个结构体,每一项的指数作为数组的索引系数作为值,这样在读入时,直接找到对应位置进行修改,对数组的访问是很快的。
  • 之后一次遍历,统计出数组不为0的个数,就是非零项的个数;然后对数组从后往前输出每个非零项对应的下标和值,就是结果。

代码

#include <iostream>
using namespace std; int main() {
// 指数作为下标,系数作为值,题目给出指数最多为1000
float pols[1001] = {0};
int k, exp;
float coe;
int cnt = 0;
// 每一个样例是两行
for (int i = 0; i < 2; ++i) {
// 第一个整数是说明后面有几个非0项
cin >> k;
for (; k > 0; --k) {
// 指数 系数 指数 系数
cin >> exp >> coe;
pols[exp] += coe;
}
}
// 统计非零项
for (int i = 0; i < 1001; ++i) {
if (pols[i] != 0) cnt++;
}
// 输出非零项个数
cout << cnt;
// 按 指数 系数,从高到底输出,空格分隔
for (int i = 1000; i >= 0; --i) {
if (pols[i] != 0) {
printf(" %d %.1f", i, pols[i]);
}
} return 0;
}

最新文章

  1. oracle rman catalog备份和恢复
  2. C# 获取当前路径7种方法
  3. 用volley在Genymotion上获取网页源码
  4. 四则运算APP(BUG发掘)
  5. Nmap备忘单:从探索到漏洞利用(Part 4)
  6. BZOJ 3983 Takeover Wars 解题报告
  7. Linux中的搜索命令
  8. Qt开发小工具之gif转换器(使用QMovie截取每一帧为QImage,然后用QFile另存为图片文件)
  9. Linux下同步工具inotify+rsync使用详解
  10. 【SqlServer系列】表达式(expression)
  11. 痞子衡嵌入式:飞思卡尔i.MX RT系列MCU特性介绍(3)- 命名规则
  12. JAVA String类型和原型模式
  13. Laravel -- 邮箱功能配置问题
  14. Design Principle, Design Patterns And Refactoring
  15. java截取2个指定字符之间的字符串
  16. &quot;Error 0162 - Setup data integrity check failure&quot; after updating BIOS via Thinkvantage
  17. BZOJ1076 [SCOI2008]奖励关 概率 状态压缩动态规划
  18. C++设计模式 之 “对象创建”模式:Factory Method、Abstract Factory、Prototype、Builder
  19. 深水划水队项目---七天冲刺之day4
  20. maven web不能创建src/main/java等文件等问题

热门文章

  1. java 多线--静态代理模式
  2. audio的自动播放报错解决
  3. 第八次-非确定的自动机NFA确定化为DFA
  4. [源码分析]从&quot;UDF不应有状态&quot; 切入来剖析Flink SQL代码生成 (修订版)
  5. 利用python画出SJF调度图
  6. Spring Boot filter
  7. 标准库ConfigParser模块
  8. composer+psr-4实现自动加载
  9. LightOJ 1287 Where to Run(期望)
  10. 交换机上的MAC地址表