Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9650   Accepted: 6856

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn −
1
 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod
10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

和普通的高速幂的写法同样,不同的是须要计算矩阵相乘,仅仅要写对矩阵的乘法,就没难度了
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define LL long long
struct node{
LL s11 , s12 , s21 , s22 ;
};
node f(node a,node b)
{
node p ;
p.s11 = (a.s11*b.s11 + a.s12*b.s21)%10000 ;
p.s12 = (a.s11*b.s12 + a.s12*b.s22)%10000 ;
p.s21 = (a.s21*b.s11 + a.s22*b.s21)%10000 ;
p.s22 = (a.s21*b.s12 + a.s22*b.s22)%10000 ;
return p ;
}
node pow(node p,int n)
{
node q ;
q.s11 = q.s22 = 1 ;
q.s12 = q.s21 = 0 ;
if(n == 0)
return q ;
q = pow(p,n/2);
q = f(q,q);
if( n%2 )
q = f(q,p);
return q ;
}
int main()
{
int n ;
node p ;
while(scanf("%d", &n) && n != -1)
{
p.s11 = p.s12 = p.s21 = 1 ;
p.s22 = 0 ;
p = pow(p,n);
printf("%d\n", p.s12);
}
return 0;
}

最新文章

  1. 编写高质量代码:改善Java程序的151个建议(第1章:JAVA开发中通用的方法和准则___建议16~20)
  2. Mybatis关联查询(嵌套查询)
  3. Delphi XE8,C++ Builder XE8,RAD Studio XE8 官方 ISO 文件下载,附激活工具
  4. Revit二次开发示例:DisableCommand
  5. 使用pgbench测试PostgreSQL
  6. table的边框线的设置
  7. WINDOWS2008 设置FTP防火墙规则
  8. Windows 环境下基于 Redis 的 Celery 任务调度模块的实现
  9. dut1305 台阶
  10. bit,byte,char,string区别与基本类型认识
  11. noip 2015 提高组
  12. 【C++基础之十五】内联函数
  13. springmvc学习笔记(理论)
  14. 用C#实现网络爬虫(二)
  15. JVM虚拟机选项:Xms Xmx PermSize MaxPermSize区别(转)
  16. 测试Data ORM的性能
  17. jquery.range.js左右滑动选取数值插件,动态改变进度。
  18. redmine工作流程总结
  19. 【Unity Shaders】Alpha Test和Alpha Blending
  20. cmake 入门实战

热门文章

  1. EasyUI实战经验总结(转)
  2. C指针决心 ------ 指针的概念和元素
  3. win7下go web之revel
  4. IIS7和IIS7.5备份和还原的方法
  5. java提高篇(十四)-----关键字final
  6. YUV摘要格式
  7. php中国的垃圾问题
  8. c# 16进制显示转化
  9. JS它DOM
  10. SDUT OJ 2463 学校password你必须学会科学计划