N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 53785    Accepted Submission(s): 15217

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1

2

3

Sample Output

1

2

6

#include<stdio.h>
#include<string.h>
const int maxn=50000; //数组开到50000就能够满足10000的阶乘不越界
int fun[maxn];
int main()
{
int i,j,n;
while(~scanf("%d",&n))
{ memset(fun,0,sizeof(fun));
fun[0]=1;
for(i=2;i<=n;i++) //从2的阶乘開始,一直到指定数的阶乘
{
int c=0;
for(j=0;j<maxn;j++) //将所得阶乘数放在fun数组中,低位放在fun[0]中
{
int s=fun[j]*i+c;
fun[j] =s%10;
c=s/10;
}
} for(j=maxn-1;j>=0;j--) //找出该数的最高位,即数组角码最大且不为0的数
if(fun[j]) break;
for(i=j;i>=0;i--)
printf("%d",fun[i]);
printf("\n");
}
return 0;
}

最新文章

  1. Light oj1031 Easy Game (区间dp)
  2. 设置UIImage的渲染模式:UIImage.renderingMode
  3. JAVA设计模式 之 观察者模式
  4. httpclient 支持代理和http &amp; https
  5. 关于cnas培训
  6. JavaScript实现,判断一个点是否在多边形内
  7. javascript 中$符号是代表什么意思!
  8. HDU 3549 Flow Problem 流问题(最大流,入门)
  9. less的学习(css)
  10. CSS实现强制换行-------Day 78
  11. 基于visual Studio2013解决C语言竞赛题之1017次数
  12. shell入门之流程控制语句
  13. WEB前端开发常见问题汇总
  14. idea spring-boot总结
  15. Pandas 基础(13) - Crosstab 交叉列表取值
  16. Linux下Apache的安装【可用】
  17. css设置点击态样式
  18. OKHttpUtil工具类
  19. hdu3488 Tour 拆点+二分图最佳匹配
  20. POJ 1087 A Plug for UNIX / HDU 1526 A Plug for UNIX / ZOJ 1157 A Plug for UNIX / UVA 753 A Plug for UNIX / UVAlive 5418 A Plug for UNIX / SCU 1671 A Plug for UNIX (网络流)

热门文章

  1. Azkaban安装部署
  2. html 自定义标签使用实现方法
  3. 实现一个websocket服务器-理论篇
  4. day3--远程链接Linux
  5. Input类型是checkbox时checked属性获取
  6. Nginx服务及编译安装
  7. JVM命令
  8. python进阶------进程线程(一)
  9. python基础-------模块与包(四)
  10. Python字符串之StringIO和struct