At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
思路
代码
#include<bits/stdc++.h>
using namespace std;
struct node
{
char name[20];
int hh,mm,ss;
}small, big; void Init()
{
big.hh = big.mm = big.ss = 0;
small.hh = 24;
small.mm = small.ss = 59;
} bool early(node a, node b)
{ //true-a的时间早于b的时间
if(a.hh != b.hh) return a.hh <= b.hh;
else if(a.mm != b.mm) return a.mm <= b.mm;
else return a.ss <= b.ss;
}
int main()
{
int m;
cin >> m;
Init(); node tmp;
while(m--)
{
scanf("%s %d:%d:%d", &tmp.name, &tmp.hh, &tmp.mm, &tmp.ss);
if(early(tmp, small))
small = tmp; //更新最早
scanf("%d:%d:%d", &tmp.hh, &tmp.mm, &tmp.ss);
if(early(big, tmp))
big = tmp; //更新最晚
}
cout << small.name << " " << big.name;
return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805516654460928

最新文章

  1. swfit-学习笔记(表UITableView的简单使用)
  2. 关于 js 一些基本的东西
  3. python 入门(一)矩阵处理
  4. 2016-2017 ACM-ICPC Asia-Bangkok Regional Contest
  5. Java注释Override、Deprecated、SuppressWarnings详解(过时方法,即将删除的方法或成员变量)
  6. vector的 emplace 和 insert 以及使用vector进行iterator遍历 且 erase的时候注意事项
  7. @ModelAttribute注解的作用
  8. Tomcat发布项目时,浏览器地址栏图标的问题
  9. 【转载】Android异步处理系列文章
  10. careercup-排序和查找 11.5
  11. ubuntu15.10升级时校验和不符的解决方法
  12. Google为何这么屌
  13. php开启错误提示
  14. ARP协议的报文格式 转自n哖苡逅
  15. NYOJ--32--SEARCH--组合数
  16. eviews 9.5新版本——平均预测、面板效应检验
  17. springboot集成schedule(深度理解)
  18. Ocelot + Consul实践
  19. java快排思想
  20. zookeeper应用与原理学习总结

热门文章

  1. Binding使用的属性、DataContext上下文绑定必须使用的情况
  2. 面试题:MySQL索引为什么用B+树?
  3. axios的post请求方式,怎么把参数直接加在URL后面,不用payload
  4. puppet自动化部署
  5. Python使用otp实现二步验证
  6. MVC中上传文件
  7. 石川es6课程---5、函数-参数
  8. [svc]linux中的文件描述符(file descriptor)和文件
  9. IIS asp.net 中出现未能加载文件或程序集“System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”或它的某一个依赖项。系统找不到指定的文件。
  10. 阶段3 3.SpringMVC&#183;_06.异常处理及拦截器_2 SpringMVC异常处理之演示程序异常