Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

Submit Status

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 








The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 








For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem. 
 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above. 
 

Output

The output should contain the minimum time in minutes to complete the moving, one per line. 
 

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
 

Sample Output

10
20
30
 第一种方法,很明了
对这道题目,核心算法就是贪心了。从最小的房号開始搬运。然后将不冲突的都搬走就能够了

接着就是相邻的两个房间进行特殊处理。假设是5号房间,那么6号房间的走廊就不能用。为什么。请

看题目提供的图。所以接下来就处理过去就能够了,知道没有房间能够搬。
/*
Author: 2486
Memory: 1416 KB Time: 0 MS
Language: G++ Result: Accepted
VJ RunId: 4178448 Real RunId: 14210276
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200+5;
int t,n;
struct obje {
int s,t;
bool operator<(const obje&a)const {
return s<a.s;
}
} objes[maxn];
bool vis[maxn];
int main() {
// freopen("D://imput.txt","r",stdin);
scanf("%d",&t);
while(t--) {
scanf("%d",&n);
for(int i=0; i<n; i++) {
scanf("%d%d",&objes[i].s,&objes[i].t);
if(objes[i].s>objes[i].t)swap(objes[i].s,objes[i].t);
vis[i]=false;
}
sort(objes,objes+n);//按房号開始排序
int cnt=0;
bool flag=false;
while(true) {
int t=0;
flag=false;
for(int i=0; i<n; i++) {
if(vis[i])continue;
if((t%2==1&&t+1<objes[i].s)||(t%2==0&&t<objes[i].s)) {//相邻的房间处理,以及选取末尾比t大的房号
flag=true;
vis[i]=true;
t=objes[i].t;
}
}
if(!flag)break;
else cnt++;
}
printf("%d\n",cnt*10);
}
return 0;
}

第二种方法就是区间覆盖的方法。属于区间覆盖类型题,对于每一回合操作中记录当前覆盖的最大的值,证明这些覆盖的部分肯定不可以同一时候进行搬运,如此这里还须要一个技巧,就是将5,6或者3,4变为一个数,由于他们拥有相同的走廊。将6当做5处理。和把5当做6处理。他们都是占用同一走廊,所得到的效果是一样的

于是
/*
Author: 2486
Memory: 1408 KB Time: 0 MS
Language: G++ Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200+5;
int t,n,s,tt;
int a[maxn];
int main() {
//freopen("D://imput.txt","r",stdin);
scanf("%d",&t);
while(t--) {
memset(a,0,sizeof(a));
scanf("%d",&n);
int cnt=0;
while(n--){
scanf("%d%d",&s,&tt);
if(s>tt)swap(s,tt);
s=(s+1)>>1;//将他们5,6缩到一起。区间降低一半
tt=(tt+1)>>1;
for(int i=s;i<=tt;i++){
a[i]++;
if(a[i]>cnt)cnt=a[i];//求每一回合,区间的最大覆盖值就可以
}
}
printf("%d\n",cnt*10);
}
return 0;
}

最新文章

  1. 利用KD树进行异常检测
  2. jquery完整弹窗代码
  3. [Head First设计模式]抢票中的设计模式——代理模式
  4. winform的常用公共控件和常用属性
  5. Duang的成长——使用造字程序输入生僻字
  6. web.xml中 error-page的正确用法
  7. [转]SQL Server建立应用程序安全性和程序角色
  8. 网站常见问题及解决方法(div/css)
  9. phpcms v9 自定义分页 带下拉跳转
  10. vijos p1071新年趣事之打牌
  11. Struts2输入校验
  12. jconsole线程面板中的阻塞总数和等待总数(转)
  13. mysql的一些特殊命令
  14. JAVA中反射机制一
  15. HUST 1583 长度单位
  16. 浅析GDAL库C#版本支持中文路径问题(续)
  17. Spring_xml和注解混合方式开发
  18. HTTPS到底是个什么鬼?
  19. CVE-2018-14424 use-after-free of disposed transient displays 分析报告
  20. 【洛谷P3586】LOG

热门文章

  1. CF 某套题 O :Grid (简单BFS)
  2. HDU 6186 CS Course【前后缀位运算枚举/线段树】
  3. 洛谷——P1680 奇怪的分组
  4. 第6天-javascript事件
  5. AGC 020 B - Ice Rink Game
  6. 【分块】【bitset】hdu6085 Rikka with Candies
  7. 20162304 实验二《Java面向对象程序设计》实验报告
  8. PHP温故知新(二)
  9. &lt;摘录&gt;简述configure、pkg-config、pkg_config_path三者的关系
  10. nodejs第一个练习:用Node.js建HTTP服务器