Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16166    Accepted Submission(s): 6444

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

华东区大学生程序设计邀请赛_热身赛

Recommend

lcy

题解:

     ①KMP算法,统计匹配个数。

#include<stdio.h>
#include<cstring>
#define go(i,a,b) for(int i=a;i<=b;i++)
const int N=1000003;
int C,n,m,f[N],j,ans;char P[N],T[N];
int main()
{
scanf("%d",&C);
while(ans=0,C--&&scanf("%s%s",P,T))
{
m=strlen(P);
n=strlen(T);
f[0]=f[1]=0; go(i,1,m-1){j=f[i];while(j&&P[j]!=P[i])j=f[j];f[i+1]=P[i]==P[j]?j+1:0;}j=0;
go(i,0,n-1){while(j&&P[j]!=T[i])j=f[j];ans+=(j+=P[j]==T[i])==m;}
printf("%d\n",ans);
}
return 0;
}//Paul_Guderian

我曾经追寻的一切,现在都没有找到,
你知道我一直要的,不是这个角落…… ————汪峰《彼岸》

最新文章

  1. Android笔记——关于Cursor类的介绍
  2. 试试看 ? 离奇古怪的javascript题目
  3. JS 对象
  4. appsrequest v3 发布了
  5. Python基础篇【第6篇】: Python装饰器
  6. xml序列化及反序列化.net对象
  7. 基于类和基于函数的python多线程样例
  8. Python与Hack之window下运行带参数的Python脚本,实现一个简单的端口扫描器
  9. 百度ueditor 拖文件或world 里面复制粘贴图片到编辑中 上传到第三方问题
  10. 《如何阅读一本书》(How to Read a Book)
  11. java中的==、equals()、hashCode()源码分析
  12. Coursera 机器学习笔记(三)
  13. C++笔记之关键字explicit
  14. 浅析vue实例的生命周期(生命周期钩子)
  15. centos安装ruby
  16. 【JMeter】【性能测试】服务器性能监控
  17. (转)【学习笔记】通过netstat+rmsock查找AIX端口对应进程
  18. [转]Windows上搭建Kafka运行环境
  19. 使用 Azure CLI 创建和管理 Linux VM
  20. ArcGis API for JavaScript学习——加载地图

热门文章

  1. Symfony相关网站参考
  2. JQuery的checkbox全选与全不选操作
  3. Access数据库远程连接的实用方法
  4. 快速下载jar包
  5. IATHook
  6. windows_Bat_Scripts查看系统IP-更改regedit-更新系统补丁
  7. 跨域问题和django中实现跨域
  8. oracle insert用法总结
  9. hdu 1257最少拦截系统
  10. Scrapy的架构与原理的理解【转】