题目例如以下:

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length.
So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best
solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200)
followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by
a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

这道题目,依照正常的思路求解,应该使用最长公共子序列算法LCS,但与常规的LCS有所区别。常规LCS是从两个序列中按索引递增顺序,不反复的选取最大公共子列,而如今的问题是在序列B中依照A中的元素顺序可反复的找出最大子列,这样说起来比較抽象,以下举个样例,对于序列:

A={2,3,1,5,6} B={2,2,4,1,5,5,6,3,1,1,5,6}

假设是常规的LCS,我们找到的子列将会是{2,3,1,5,6},由于B全然的包括了A(不必连续)

假设是可反复的LCS。我们全然能够选择{2,2,3,1,1,5,6}。这便是变种的LCS。

对于常规的LCS(关于LCS的算法请參考算法导论390页15.4节),仅仅有A[i] = B[j]时才让当前的最大子列长度为maxLen[i-1][j-1]+1。其它情况则取maxLen[i-1][j]或者maxLen[i][j-1]中的最大值,这种算法仅仅能不反复的找出子列,假设要考虑反复,应该改动算法,不管什么情况,都取maxLen[i-1][j-1]、maxLen[i-1][j]和maxLen[i][j-1]中的最大值,假设A[i]=B[j],则在最大值的基础上+1,这样就能够处理反复的情况了。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector> using namespace std; int maxLen[201][10001] = {0}; int main()
{
int N,M,L;
cin >> N;
cin >> M;
vector<int> like(M+1);
int num;
for(int i = 1; i <= M; i++){
scanf("%d",&num);
like[i] = num;
}
cin >> L;
vector<int> seq(L+1);
for(int i = 1; i <= L; i++){
scanf("%d",&num);
seq[i] = num;
}
int max = 0;
for(int m = 1; m <= M; m++){
for(int n = 1; n <= L; n++){
max = maxLen[m-1][n-1];
if(max < maxLen[m-1][n]) max = maxLen[m-1][n];
if(max < maxLen[m][n-1]) max = maxLen[m][n-1];
if(like[m] == seq[n]){
maxLen[m][n] = max + 1;
}else{
maxLen[m][n] = max;
}
// if(like[m] == seq[n]){
// maxLen[m][n] = maxLen[m-1][n-1] + 1;
// }else if(maxLen[m-1][n] >= maxLen[m][n-1]){
// maxLen[m][n] = maxLen[m-1][n];
// }else{
// maxLen[m][n] = maxLen[m][n-1];
// }
}
} cout << maxLen[M][L] << endl; return 0;
}

最新文章

  1. 景区3D指纹验证系统解决方案
  2. Linux系统管理命令之权限管理
  3. C++ 基础 构造函数的使用
  4. 转载 jquery $(document).ready() 与window.onload的区别
  5. 使用ADO连接oracle数据库“未找到提供程序。该程序可能未正确安装”解决方案
  6. 3. opencv进行SIFT特征提取
  7. Gson序列化对象时排除字段
  8. 安装 SQL Server 2008 R2 的硬件和软件要求(转)
  9. Java的HashCode
  10. PHP入门学习精要
  11. 这可能是最简单的Page Object库
  12. .NET Core实战项目之CMS 第七章 设计篇-用户权限极简设计全过程
  13. P2678 跳石头(二分+模拟)
  14. HDOJ 2001 ASCII码排序
  15. Android -- Canvas java.lang.UnsupportedOperationException
  16. Redis学习 - 主从拷贝
  17. Docker应用四:搭建docker镜像仓库(包括自生成https证书、登陆认证)
  18. TCP/IP 网络编程的理解
  19. 在eclipse中安装TestNG
  20. Jenkins中Jelly邮件模板的配置

热门文章

  1. springBoot Feign Hystrix
  2. 最新版 VS2015|Visual Studio Enterprise 2015简体中文版(企业版)
  3. 【BZOJ3524】Couriers
  4. 集合框架(02)List
  5. Chrome下强制http重定向到https的问题
  6. Linux下查看某个进程的网络带宽占用情况
  7. 在sqlserver中如何从字符串中提取数字,英文,中文,过滤重复字符
  8. delphi 浮点数转换成十六进制字符串的方法
  9. tiny4412 串口驱动分析一 --- u-boot中的串口驱动
  10. c#异步线程:同步调用,异步调用,异步回调