Problem C: 动态规划基础题目之数字三角形

Time Limit: 1 Sec  Memory Limit: 64 MB
Submit:
208  Solved: 139
[Submit][Status][Web Board]

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5 (Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30
#include<stdio.h>
int main()
{
int a[20][20];
int i,j;
int n;
scanf("%d",&n);
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);
for(i=n;i>=1;i--)
{
for(j=1;j<=i;j++)
{
a[i-1][j]+=(a[i][j]>a[i][j+1]?a[i][j]:a[i][j+1]);
}
}
printf("%d",a[1][1]);
return 0;
}

  

 

最新文章

  1. 从sum()求和引发的思考
  2. BroadcastReceiver注册、使用及其权限
  3. css3之文本新属性
  4. NBIbatis 基础框架
  5. 【python cookbook】【数据结构与算法】18.将名称映射到序列的元素中
  6. hdu4418(概率dp + 高斯消元)
  7. IIS报错 未将对象引用设置到对象的实例。
  8. Java常用类库
  9. APK签名校验绕过
  10. Delphi REST和Cloud Services
  11. C语言——打印魔方阵(每一行,每一列,对角线之和相等)
  12. MySQL5.6监控表之INNODB_METRICS
  13. Radis安装
  14. Unity3D Shader Stencil模版测试学习
  15. angular ng-bind
  16. 设置应用栏(Setting Up the App Bar)
  17. Lua中的类型与值
  18. MongoDB在CentOS上的安装和配置
  19. QQ设置手机和pc qq群消息不同步
  20. javascript 之 第七章第一节(递归)

热门文章

  1. java socket 网络通信 指定端口的监听 多线程 乱码
  2. E 聪明的“KK”
  3. Windows平台Anaconda使用笔记
  4. PAT甲级——1093 Count PAT&#39;s (逻辑类型的题目)
  5. 安居客scrapy房产信息爬取到数据可视化(上)-scrapy爬虫
  6. java程序生成二维码
  7. 上传图片时实时显示功能使用uploadPreview.js
  8. Codeforces 1161B(判断旋转对称)
  9. CF C. Maximal Intersection(贪心 || STL)
  10. linux使用echo指令向文件写入内容