Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17224   Accepted: 6460

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

很裸的题。

可以使用二维树状数组。

二维的写起来很方便,两重循环。

如果是要修改(x1,y1)  -  (x2,y2)的矩形区域。

那么可以在(x1,y1) 出加1,在(x2+1,y1)处加1,在(x1,y2+1)处加1,在(x2+1,y2+1)处加1 。。

画个图就知道了,查询单点就是求和。

 /* ***********************************************
Author :kuangbin
Created Time :2014/5/23 22:34:04
File Name :E:\2014ACM\专题学习\数据结构\二维树状数组\POJ2155.cpp
************************************************ */ #include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int MAXN = ;
int lowbit(int x)
{
return x&(-x);
}
int c[MAXN][MAXN];
int n;
int sum(int x,int y)
{
int ret = ;
for(int i = x;i > ;i -= lowbit(i))
for(int j = y;j > ;j -= lowbit(j))
ret += c[i][j];
return ret;
}
void add(int x,int y,int val)
{
for(int i = x;i <= n;i += lowbit(i))
for(int j = y;j <= n;j += lowbit(j))
c[i][j] += val;
} int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int T;
scanf("%d",&T);
while(T--)
{
int q;
scanf("%d%d",&n,&q);
memset(c,,sizeof(c));
char op[];
int x1,y1,x2,y2;
while(q--)
{
scanf("%s",op);
if(op[] == 'C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
add(x1,y1,);
add(x2+,y1,);
add(x1,y2+,);
add(x2+,y2+,);
}
else
{
scanf("%d%d",&x1,&y1);
if(sum(x1,y1)% == )printf("0\n");
else printf("1\n");
}
}
if(T > )printf("\n");
}
return ;
}

最新文章

  1. linux中Makefile文件相关内容
  2. LayaAir引擎——(六)
  3. clientWidth、offsetWidth和scrollWidth的区分
  4. Eclipse下link方式安装插件
  5. HLG2035广搜
  6. setattribute兼容
  7. c++课程实训 银行储蓄系统
  8. DNA比对
  9. Activity的启动过程
  10. oracle查询表信息
  11. poj2386Lake Counting
  12. WCF(远程服务器返回错误: 400 错误的请求)
  13. python3-随机生成10位包含数字和字母的密码
  14. lua时间戳和日期转换及踩坑
  15. [转] ReactJS之JSX语法
  16. DockerSwarm+Dubbo镜像与部署相关命令与参数
  17. 描述性统计的matlab实现
  18. 关于swagger-ui 参数为中文的时候,后端乱码
  19. 使用sync 修饰符------子组件内部可以修改props
  20. Grin v0.5在Ubuntu下的安装和启动

热门文章

  1. hiho一下120周 后缀数组一&#183;重复旋律
  2. 盯盯拍Android App 3.0指导
  3. unity, terrain道出为obj
  4. Apache Shiro 使用手册(三)Shiro 授权
  5. mpstat, pidstat, iostat和sar
  6. cg资讯网址
  7. (整理)SQLServer_DBA 工具
  8. 利用反射及JDBC元数据编写通用查询方法
  9. ThinkPHP的路由形式
  10. Contos7 装bcm4312无线网卡驱动