Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4343    Accepted Submission(s): 1541

Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

 
Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

 
Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

 
Sample Input
2
4 0
3 2
1 2
1 3
 
Sample Output
4
2
 
#include <bits/stdc++.h>
using namespace std;
const int N = 20005;
const int M = 50005; struct edge {
int v, next;
edge() {}
edge(int v, int next): v(v), next(next) {}
}e[M], e2[M]; int head[N], head2[N], num[N], in[N], out[N], tot, tot2;
int low[N], dfn[N], Stack[N], belong[N];
int scc, Index, top;
bool Instack[N]; void addedge(int u, int v, bool is) {
if(is) {
e[tot] = edge(v, head[u]);
head[u] = tot++;
}else {
e2[tot2] = edge(v, head2[u]);
head2[u] = tot2++;
}
} void Tarjan(int u) {
int v;
low[u] = dfn[u] = ++Index;
Stack[top++] = u;
Instack[u] = true;
for(int i = head[u]; ~i; i = e[i].next) {
v = e[i].v;
if(!dfn[v]) {
Tarjan(v);
if(low[u] > low[v]) low[u] = low[v];
}else if(Instack[v] && low[u] > dfn[v]) {
low[u] = dfn[v];
}
} if(low[u] == dfn[u])
{
scc++;
do {
v = Stack[--top];
Instack[v] = false;
belong[v] = scc;
num[scc]++;
} while(v != u);
}
} void solve(int n)
{
memset(dfn, 0, sizeof dfn);
memset(Instack, false, sizeof Instack);
memset(num, 0, sizeof num);
Index = scc = top = 0;
for(int i = 1; i <= n; ++i) if(!dfn[i]) Tarjan(i);
}
void init() {
tot = tot2 = 0;
memset(head, -1, sizeof head);
memset(head2, -1, sizeof head2);
} int main()
{
int _; scanf("%d", &_);
while(_ --)
{
init();
int n, m, u, v;
scanf("%d%d", &n, &m);
for(int i = 1; i <= m ;++i) {
scanf("%d%d", &u, &v);
addedge(u, v, true);
}
solve(n);
memset(in, 0, sizeof in);
memset(out, 0, sizeof out); for(int u = 1; u <= n; ++u) {
for(int i = head[u]; ~i; i = e[i].next) {
int v = e[i].v;
if(belong[u] != belong[v]) {
addedge(belong[u], belong[v], false);
}
}
}
for(int u = 1; u <= scc; ++u) {
for(int i = head2[u]; ~i; i = e2[i].next) {
int v = e2[i].v;
in[v]++;
out[u]++;
}
}
int a = 0, b = 0;
for(int i = 1; i <= scc; ++i) {
if(in[i] == 0) a++;
if(out[i] == 0) b++;
}
printf("%d\n", scc == 1 ? 0 : max(a, b));
}
return 0;
}

  

 
Source

最新文章

  1. [每天默写一个算法]KMP
  2. python高性能代码之多线程优化
  3. chmod和fchmod函数 /chown ,fchown,lchown函数
  4. lazyload懒加载的使用
  5. PHP 防范IP攻击
  6. Scala模式匹配语言,java的替代者
  7. 关于BaseAdapter的使用及优化心得(一)
  8. jquery ajax发送delete(use in jquery file upload delete file)
  9. js中的运算符和条件语句
  10. C# 中的委托和事件[转自张子扬]
  11. Android Studio 工程.GitIgnore应该忽略的文件
  12. 【1】ShopNC 模仿笔记(一)
  13. 修改虚拟机内容导致oracle不能启动
  14. Introducing &#39;bind&#39;
  15. C++的精髓——虚函数
  16. 分布式环境中三种Session管理方法的使用场景及优缺点
  17. SQL 结合CASE WHEN 实现二维统计
  18. CSS 水平居中/布局 垂直居中 (月经问题)
  19. Vue 闪现解决
  20. Python 面向对象编程(进阶部分)

热门文章

  1. UVA 156 Ananagrams ---map
  2. September 25th 2016 Week 40th Sunday
  3. Python--常见问题解决方案
  4. 模拟赛1031d2
  5. 关于jQuery新的事件绑定机制on()的使用技巧
  6. 自定义UIDatePikerView
  7. Codeforces Round #324 (Div. 2) C (二分)
  8. 关于android的单位dp与px
  9. 登录到mysql查看binlog日志
  10. 查看当前文件系统 df -lhT -B G