Stars

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 39186 Accepted: 17027

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

题目大意:给定各星星x,y坐标,保证给出时有序,统计每个等级的星星个数,等级为x,y坐标都不超过当前星星的星星数

开始想到可以把二维降到一维,然后没仔细看题想了一会,有点思路后看了眼题,发现题目早已人性的排好序了。。。
于是变成了裸题,水过,水水水...
裸的不能再裸的树状数组了...

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxx 32002
#define maxn 15000
int sum[maxx]={0};
int num[maxn]={0};
int n; int lowbit(int x)
{
return x&(-x);
} int add(int loc,int num)
{
while (loc<=maxx)
{
sum[loc]+=num;
loc+=lowbit(loc);
}
} int query(int loc)
{
int total=0;
while (loc>0)
{
total+=sum[loc];
loc-=lowbit(loc);
}
return total;
} int main()
{
scanf("%d",&n);
for (int i=1; i<=n; i++)
{
int x,y;
scanf("%d%d",&x,&y);
add(x+1,1);//因为x可以取到0,为了防止x=0时死掉,都横坐标+1处理(此题唯一需要注意的地方)...
num[query(x+1)-1]++;
}
for (int i=0; i<=n-1; i++)
printf("%d\n",num[i]);
return 0;
}

最新文章

  1. DataTable与DTO对象的简易转换类
  2. DuBrute 3.1
  3. spring boot启用tomcat ssl
  4. 使用vs2010创建MFC C++ Ribbon程序
  5. JSP页面组件
  6. HTTP Status 500 - Servlet.init() for servlet springmvc threw exception
  7. NUI控件扩展
  8. (转)2G到C-RAN网络架构的演进
  9. C语言中的struct和typedef struct&lt;转载&gt;
  10. MYSQL查看和修改存储引擎
  11. Spring MVC---基于注解的控制器
  12. Jquery实现表格的分页
  13. select应用于read函数 超时非阻塞方式
  14. 静态方法和实例方法(mark)
  15. hadoop day 2
  16. 字节顺序标记BOM
  17. Hadoop生态圈-Flume的组件之sink处理器
  18. python 包详解
  19. Python 文件 seek() 方法
  20. Swift Tips笔记

热门文章

  1. Vector3D - AS3
  2. php遇上iis之上传突破
  3. 时间与NSString转换
  4. 第二章 rabbitmq在mac上的安装
  5. Table AdvanceTable针对表内行禁用multipleSelection , singleSelection
  6. 文件“D:\file.txt”正由另一进程使用,因此该进程无法访问该文件。
  7. 微信公众平台开发之微信access_token如何有效长期保存
  8. Web消息主体风格(Message Body Style)
  9. Linux(9.28-10.4)学习笔记
  10. VS2010下配置使用OpenGL的glut库