Tunnel Warfare
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 7876   Accepted: 3259

Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!

Input

The first line of the input contains two positive integers n and m (nm ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

  1. D x: The x-th village was destroyed.
  2. Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.
  3. R: The village destroyed last was rebuilt.

Output

Output the answer to each of the Army commanders’ request in order on a separate line.

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4

Sample Output

1
0
2
4

Hint

An illustration of the sample input:

      OOOOOOO

D 3   OOXOOOO

D 6   OOXOOXO

D 5   OOXOXXO

R     OOXOOXO

R     OOXOOOO

题目链接:POJ 2892

线段树的区间合并操作相比其他区间操作稍微难理解,但是还是可以写的一下的,主要就是对pushup和query的修改

做法就是seg数据里记录当前区间从左边即seg::l 开始向右连续连通长度,记为L,从右边seg::r 开始的向左连续连通长度,记为R。用seg::M表示是区间中最大的连续连通长度,显然M应该有三种情况,要么为L要么为R要么为左子树的R+右子树的L,最后的情况是必然会要比较的,但是前两种不一定会出现,比如左子树的L并没有达到父节点的mid即左子树的r,因此中间断开了,父节点的L仍时保持为左子树的L,父节点的R也相同道理,然后三者取一个最大的就得到了父节点的M,然后是L和R如何更新就看左子树的L和右子树的R是否完全覆盖了子区间,若完全覆盖则父节点的L与R可以拓展延长……

还有就是查询的时候加一个剪枝条件不然容易TLE,若当前区间已经完全覆盖或者最大连通长度M为0显然是不需要再递归查询的直接返回即可。

代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <sstream>
#include <numeric>
#include <cstring>
#include <bitset>
#include <string>
#include <deque>
#include <stack>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=50010;
struct seg
{
int l,mid,r;
int L,M,R;
int len;
};
seg T[N<<2];
int st[N],top; inline void pushup(int k)
{
T[k].L=T[LC(k)].L;
T[k].R=T[RC(k)].R; if(T[k].L==T[LC(k)].len)
T[k].L+=T[RC(k)].L;
if(T[k].R==T[RC(k)].len)
T[k].R+=T[LC(k)].R; T[k].M=max<int>(T[LC(k)].R+T[RC(k)].L,max<int>(T[LC(k)].M,T[RC(k)].M));
}
void build(int k,int l,int r)
{
T[k].l=l;
T[k].r=r;
T[k].mid=MID(l,r);
T[k].len=r-l+1;
T[k].L=T[k].R=T[k].M=r-l+1;
if(l==r)
return ;
build(LC(k),l,T[k].mid);
build(RC(k),T[k].mid+1,r);
}
void update(int k,int x,char flag)
{
if(T[k].l==T[k].r)
{
if(flag=='D')
T[k].L=T[k].R=T[k].M=0;
else
T[k].L=T[k].R=T[k].M=1;
}
else
{
if(x<=T[k].mid)
update(LC(k),x,flag);
else
update(RC(k),x,flag);
pushup(k);
}
}
int query(int k,int x)
{
if(T[k].M==T[k].len||!T[k].M||T[k].len==1)
return T[k].M;
else
{
if(x<=T[k].mid)
{
if(x>=T[k].mid+1-T[LC(k)].R)
return query(LC(k),x)+query(RC(k),T[k].mid+1);
else
return query(LC(k),x);
}
else
{
if(x<=T[k].mid+T[RC(k)].L)
return query(LC(k),T[k].mid)+query(RC(k),x);
else
return query(RC(k),x);
}
}
}
int main(void)
{
char ops[3];
int n,m,x;
while (~scanf("%d%d",&n,&m))
{
top=0;
build(1,1,n);
while (m--)
{
scanf("%s",ops);
if(ops[0]=='D')
{
scanf("%d",&x);
update(1,st[top++]=x,'D');
}
else if(ops[0]=='Q')
{
scanf("%d",&x);
printf("%d\n",query(1,x));
}
else
update(1,st[--top],'R');
}
}
return 0;
}

最新文章

  1. centos 安装beanstalkd
  2. CentOS 6.6 新安装系统的网络IP配置
  3. [NOIP2014] 提高组 洛谷P2038 无线网络发射器选址
  4. Cocos2d-x分类
  5. 浅析游戏引擎的资源管理机制——扒一扒Unity3D中隐藏在背后的资源管理
  6. C#中调用存储过程
  7. ASP.NET Web Service如何工作(1)
  8. php循环生成的表单如何获得其各项值案例
  9. Java经典案例之-“最大公约数和最小公倍数”
  10. Select的逻辑处理顺序(Transact-SQL)
  11. Lock使用实例
  12. 关于SVN工具的配置及使用
  13. 设计模式 | 简单工厂模式(static factory method)
  14. (70)Wangdao.com第十一天_JavaScript 日期对象 Date
  15. oracle表的基本操作
  16. 微信小程序开发笔记01
  17. Windows CreateFont:创建自己的字体
  18. C#中decimal ,double,float的区别
  19. ROS开发与常用命令
  20. try....fail....catch...Assert 模式的测试, fail是Junit中的功能

热门文章

  1. JavaScript当离开页面时可以进行的操作
  2. plsql查询数据显示为乱码解决方法
  3. 一、HTML和CSS基础--HTML+CSS基础课程--第4部分
  4. linux下绘图工具dia
  5. Android项目环境搭建
  6. TabLayout
  7. XmlPull
  8. Seismic Unix的一些历史
  9. 模拟 POJ 2632 Crashing Robots
  10. API分析——Jquery UI Dialog