Exponentiation
Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 145642   Accepted: 35529

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

高精度乘法 问了下晖哥ICPC比赛时可以用多种语言混合提交 这里就给出Java的写法 建议掌握Java的大数类

C++的版本自己感兴趣的自己去敲一敲好了 把小数点去掉乘法最后加上小数点就好了

import java.math.BigDecimal;
import java.util.Scanner; public class Main {
public static void main(String[] args) {
@SuppressWarnings("resource")
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
BigDecimal bd = new BigDecimal(sc.next());
BigDecimal result = bd.pow(sc.nextInt());
String s = result.stripTrailingZeros().toPlainString();
if (s.startsWith("0"))
s = s.substring(1);
System.out.println(s);
}
}
}

最新文章

  1. 阿里云的9折推荐码 8DIER4
  2. C#:IText构造PDF文件
  3. Java基础知识强化之IO流笔记45:IO流练习之 把集合中的数据存储到文本文件案例
  4. iOS获取设备唯一编号,就算删除app从新安装也不变的方法
  5. docker 创建mysql镜像,并成功进行远程连接
  6. pm2日志管理pm2-logrotate介绍
  7. 【转】C盘不能扩展卷怎么回事 C盘扩展卷灰色的解决办法
  8. pycharm 中自动补全代码提示前符号 p,m ,c,v, f 是什么意思
  9. jenkins中配置svn 出现absolute path is not allowed
  10. algid parse error, not a sequence错误
  11. memmove 对同一个指针不操作
  12. PLSQL导出表结构
  13. 前端PHP入门-017-系统内置函数-会查阅API
  14. java工具jar包—Lombok
  15. DP问题如何确定状态
  16. [总结]Perl在遇到Unicode字符文件名时的各种处理方法
  17. android studio的弹出层
  18. linux-统计文件中相同行的数量
  19. ViewPager+Fragment基本使用方法(附源码)
  20. Linux下Java、Maven、Tomcat的安装

热门文章

  1. __block修饰变量以及代码块的用法
  2. X删除数据表的新用法
  3. WordPress博客平台的搭建--基于Ubuntu14服务器
  4. GUI
  5. Python Django 数据库操作
  6. 架构设计 - Server设计草稿
  7. [BZOJ 2038]小Z的袜子
  8. 在Unity中创建可远程加载的.unity3d包
  9. c语言结构体&amp;常指针和常量指针的区别
  10. linux git 推送空文件夹