Wireless Network
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 25022   Accepted: 10399

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

原题大意:给两个整数N和d,N为电脑的个数,d为无线传播的最远距离。
              接下来给N行,表示N台电脑的坐标。
              直到输入结束,都会输入一个字符,如果为O,则再输入一个整数x表示编号为x的电脑被修好。
              如果为S,再输入两个整数x,y,询问x与y之间是否连通。
解题思路:对于每台电脑一旦修好,判断与它可以连通的点的集合并合并。
              询问的时候用并查集寻找即可。其实还是一个裸并查集。
#include<stdio.h>
#include<string.h>
#include<math.h>
#define dist(x1,y1,x2,y2) (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)
int father[10050],n,d;
bool ingragh[10050];
struct node
{
int x,y;
}node[10050];
int find(int x)
{
if(x==father[x]) return (x);
else father[x]=find(father[x]);
return (father[x]);
}
void merge(int x,int y)
{
int find_x=find(x);
int find_y=find(y);
if(find_x!=find_y&&dist(node[x].x,node[x].y,node[y].x,node[y].y)<=d*d)
father[find_x]=find_y;
return;
}
void init()
{
int i;
for(i=1;i<=n;++i) father[i]=i;
memset(ingragh,false,sizeof(ingragh));
}
int main()
{
int i,query1,query2;
char c;
scanf("%d%d",&n,&d);
init();
for(i=1;i<=n;++i) scanf("%d%d",&node[i].x,&node[i].y);
while(~scanf("%c%d",&c,&query1))
{
if(c=='O')
{
for(i=1;i<=n;++i) if(ingragh[i]) merge(i,query1);
ingragh[query1]=true;
}
else
if(c=='S')
{
scanf("%d",&query2);
if(ingragh[query1]&&ingragh[query2])
{
if(find(query1)==find(query2))
{
printf("SUCCESS\n");
continue;
}
}
printf("FAIL\n");
}
}
return 0;
}

  

最新文章

  1. [BI项目记]-搭建代码管理环境之云端
  2. [Sublime Text] How to Install Sublime Text on Ubuntu
  3. 远程连接Ucenter数据库
  4. ArcGis 在线地图相关资源
  5. COJ 3007 Mr.Yang的小助手
  6. proxool数据库连接池配置
  7. 你的第一个Django程序
  8. Python全栈之路----常用模块----xml处理模块
  9. echarts X轴显示不全 有省略
  10. javaweb简单的实现文件上传
  11. xmlSpy套件(Altova MissionKit 2016)的Ollydbg调试过程及破解
  12. 软件工程_6th weeks
  13. [Java web]Spring+Struts2+Hibernate整合过程(2)
  14. [UE4]Switch on String,根据字符串决定条件分支,类似于高级语言中的switch语句
  15. VIM+ctags+cscope
  16. 【PyTorch深度学习60分钟快速入门 】Part0:系列介绍
  17. JAVA 位操作学习
  18. 【Python】【Web.py】详细解读Python的web.py框架下的application.py模块
  19. mysql与oracle常用函数及数据类型对比00持续补充
  20. (转)aix非计算内存 占用过高 案例一则

热门文章

  1. eval 简单应用
  2. No module named &#39;urllib2&#39;
  3. U盘插入电脑后,提示需要格式化U盘如何解决?
  4. 渗透杂记-2013-07-13 ms10_061_spoolss
  5. synergy 两台Windows电脑配置过程
  6. GOLANG SDK下载
  7. MySQL字符串的‘123’转换为数字的123
  8. caffe安装:ubuntu16.04 + opencv2.4 + python 2.7+ CUDA 8.0 RC + CuDNN 5.0
  9. sql连表分页查询(存储过程)
  10. WPS 认证机制