The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2044    Accepted Submission(s): 1006

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output
For each test case, output its divisor number, one line per case.

Sample Input
4
12
0

Sample Output
3
6

Author
lcy

Source
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛

Recommend
LL

#include<stdio.h>
int main()
{
__int64 n,p1,p2,p3,p4;
while (scanf("%I64d",&n)!=EOF)
{
if (n==) return ;
p1=p2=p3=p4=;
while (n && n%==)
{
p1++;
n/=;
}
while (n && n%==)
{
p2++;
n/=;
}
while (n && n%==)
{
p3++;
n/=;
}
while (n && n%==)
{
p4++;
n/=;
}
printf("%I64d\n",p1*p2*p3*p4);
}
return ;
}

最新文章

  1. 64位下pwntools中dynELF函数的使用
  2. JavaScript学习笔记-对象
  3. 什么是 A 轮融资?有 B轮 C轮么?
  4. IntelliJ IDEA 使用总结
  5. Python 列表
  6. [转载]: delphi中XLSReadWrite控件的使用(3)---基本应用
  7. Python之添加新元素
  8. 采用openFileOutput获取输出流
  9. Python自动化开发-变量、数据类型和运算
  10. JaveScript变量的简介及其变量的简单使用(JS知识点归纳一)
  11. KMP 算法 C++
  12. 单元测试系列:Mock工具Jmockit使用介绍
  13. QT—QTextEdit控件显示日志
  14. java不同的包下相同的类名的问题与解决办法
  15. centos7忘记root密码重置
  16. linux下安装tomcat和jdk
  17. 用网站(WebSite而不是WebProject)项目构建ASP.NET MVC网站
  18. 面对30页左右的运放数据手册datasheet,你需要知道如何看懂
  19. kerberos中的spn详解
  20. [Scala]Scala学习笔记四 类

热门文章

  1. UVa 11462 Age Sort
  2. [Effective JavaScript 笔记]第33条:使构造函数与new操作符无关
  3. change column to bigint
  4. myeclipse2014集成SVN
  5. MySQL之扩展(触发器,存储过程等)
  6. 找不到提交和更新按钮,subversion不见了,无法更新和上传代码
  7. Windows命令行提取日期时间
  8. 【转】js onclick用法:跳转到指定URL
  9. IE8 不支持html5 placeholder的解决方案
  10. Extjs的数据读取器store和后台返回类型简单解析