Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4 3
17 4
19 4
18 5 0

Sample Output

Scenario #1
Frog Distance = 5.000 Scenario #2
Frog Distance = 1.414

题目大意:
有N块石头,1—N。每块石头都有x,y坐标,青蛙一号站在第一块石头上,青蛙二号站在第二块石头上,
青蛙一号想要通过这N块石头去找青蛙二号,因为青蛙一号可以踩在任何一块石头上,所以从第一块石头到第二块石头有很多条路径,
假设为X,在每一条路径中,都有跳跃范围(即在这条路径中,两块石头之间的最大距离),那么一共有X个跳跃范围,
我们要求的就是这X个跳跃范围的最小值,就是the frog distance。 解题思路:
先求出所有的坐标之间的距离放入二维数组内,在判断那个是最小的。
#include<stdio.h>
#include<math.h>
#include<string.h>
const double inf=0x3f3f3f3;
int x[201],y[201];
double g[201][201],d[201],max;
int n;
void distence()
{
int i,r;
double minc;
bool used[201];
for(i=0; i<n; i++)
{
d[i]=g[0][i];
used[i]=false;
}
d[0]=0;
used[0]=true;
r=0;
while(r!=1)
{
minc=inf;
for(i=0; i<n; i++)
if(!used[i]&&d[i]<minc)
{
minc=d[i];
r=i;
}
if(minc>max) max=minc;
for(i=0; i<n; i++)
{
if(!used[i]&&g[r][i]<inf&&d[i]>g[r][i])
d[i]=g[r][i];
used[r]=true;
}
}
}
int main()
{
int cas=1;
while((scanf("%d",&n),n)!=0)
{
max=0;
for(int i=0; i<n; i++)
scanf("%d%d",&x[i],&y[i]);
memset(g,inf,sizeof(g));
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
g[i][j]=sqrt((1.0*x[i]-1.0*x[j])*(1.0*x[i]-1.0*x[j])+
(1.0*y[i]-1.0*y[j])*(1.0*y[i]-1.0*y[j]));
} distence();
printf("Scenario #%d\n",cas++);
printf("Frog Distance = %0.3lf\n",max);
printf("\n");
}
return 0;
}

  


最新文章

  1. web前端面试题汇总
  2. UITextField限制输入文字
  3. informix dbaccess 常用执行方式及常见技巧
  4. Unity摄像机的正交视图与透视图
  5. Mui - 全局css
  6. ML 徒手系列 拉格朗日乘子法
  7. .woff 文件404,配置到web.config
  8. [转]JQuery判断浏览器类型版本1.9和2.0之后的区别
  9. php 扩展编译linux
  10. easyUI的combobox设置隐藏和显示
  11. VFS四大对象之四-struct file
  12. Python内置函数(51)——hasattr
  13. 【CSS学习】--- 字体样式
  14. 如何通过SSH工具(SecureCRT、XShell)连接Vmware虚拟机中的Linux(CentOS7)
  15. ElasticSearch权威指南学习(分布式搜索)
  16. ESXi安装时遇到不识别的硬件的处理
  17. c#从基础学起string.Join(&quot;,&quot;, keys.ToArray())
  18. UI5-学习篇-3-Local SAP WEB IDE下载
  19. python 2.0 与 python 3.0 区别
  20. 转:总结const、readonly、static三者的区别

热门文章

  1. SQL语句 DML,DDL,DCL
  2. 方法的重载(overload)和重写(override)的区别
  3. linux 源码安装
  4. mongodb账号安全操作
  5. linux进程及进程控制
  6. checkbox绿色圆圈样式
  7. 一个用php实现的获取URL信息的类
  8. C/C++操作MySQL数据库——增、删、改、查
  9. _Dispose(typeinfo,pointer ); 不知道说的是什么? 感觉会有用, 留待以后研究
  10. win 7安装 linux