Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0 < Xi < Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

Input

There are multiple test cases.

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi < Yi≤N).

The input end with N=0, M=0.

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input

2 0

8 3

2 4

4 5

7 8

0 0

Sample Output

1.1667

2.3441


解题心得:

  1. 很经典的一个期望dp的题,必然事件是在第n-1个格子期望抛掷一次就结束游戏,所以从这个已知的点来推为止的期望,也就成了逆推期望。在可以飞行的点,前面的点的期望值就是其飞行到达点的期望值,然后顺其自然的就可以状态转移了。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
int to[maxn],n,m;
double dp[maxn];
void init()
{
memset(dp,0,sizeof(dp));
memset(to,-1,sizeof(to));
while(m--)
{
int s,e;
cin>>s>>e;
to[s] = e;//记录飞行的到达的点
}
} void solve()
{
for(int i=n-1;i>=0;i--)
{
if(to[i] != -1)
dp[i] = dp[to[i]];
else
{
for(int k=i+1;k<=i+6;k++)//抛出大于个格子数的点也是合法的,所以骰子每一面的可能性一直都是一样的
dp[i] += dp[k]/6.0;
dp[i] += 1.0;
}
}
printf("%.4f\n",dp[0]);
} int main()
{
while(cin>>n>>m && n+m)
{
init();
solve();
}
return 0;
}

最新文章

  1. 一个java文件中可包含多个main方法
  2. C++ 与 php 的交互 之----- C++ 获取 网页文字内容,获取 php 的 echo 值。
  3. 注解:【基于外键的】Hibernate双向1-&gt;1关联
  4. JScript中的条件注释详解(转载自网络)
  5. iOS7 隐藏状态栏 hide statusBar
  6. ubuntu mysql 使用
  7. Android模拟器访问本地的localhost失败及解决方案
  8. database disk image is malformed
  9. noip普及组2007 守望者的逃离
  10. Linux系统初始化过程及运行级别简介
  11. C#服务器端生成报告文档:使用帆软报表生成Word、Pdf报告
  12. 洛谷4月月赛R1
  13. 常用CSS样式速查
  14. 浅析vue的双向数据绑定
  15. Python学习笔记第二十周
  16. Vue热更新报错(log.error(&#39;[WDS] Errors while compiling. Reload prevented.&#39;))
  17. jetty 代码启动
  18. [GDAL]写入shp
  19. 基于Vue + Vuex + Vue-router + Webpack 2.0打造微信界面
  20. 20155212 ch03 课下作业

热门文章

  1. scrapy 一些设置和问题
  2. spark-2.2.0-bin-hadoop2.6和spark-1.6.1-bin-hadoop2.6发行包自带案例全面详解(java、python、r和scala)之Basic包下的JavaPageRank.java(图文详解)
  3. 基于vuecli3构建一个快速开发h5 APP的模板
  4. AJPFX辨析GBK和UTF8的区别
  5. oo第三单元总结
  6. text-transform字母大小写属性设置
  7. spring4、hibernate4整合xml配置
  8. Python3自动化学习地址
  9. HDU 1864 最大报销额(01背包,烂题)
  10. ActiveX、OLE和COM/DCOM