Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57430    Accepted Submission(s): 21736

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 
Author
Ignatius.L

快速幂的运用,每次相乘时余十就行

注意碰到次方很多的时候可以考虑使用快速幂了

这里贴一份讲快速幂的博客  http://blog.csdn.net/hikean/article/details/9749391

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#define ll long long
#define mod 1000000007
using namespace std;
int main()
{
int T;
cin >> T;
while(T--){
int n;
cin >> n;
int ans = ,mul = n,num = n;
mul = mul % ;
while(num){
if(num%==){
ans = (ans*mul)%;
}
mul = (mul*mul)%;
num /= ;
}
cout << ans% << endl;
}
return ;
}

最新文章

  1. [NHibernate]第一个NHibernate的应用配置
  2. iOS,多媒体,地图相关
  3. 【BZOJ 3527】【ZJOI 2014】力
  4. Python中类的运算符重载
  5. Toast,AlertDialog的误解
  6. 淘淘商城_day10_课堂笔记
  7. sed awk 小例
  8. git忽略文件并删除git仓库中的文件
  9. formdata 上传图片+进度条
  10. [cf contest697] D - Puzzles
  11. unity解压缩zip发布后的一些问题
  12. grp/从Zipkin到Jaeger,Uber的分布式追踪之道tchannel--zipkin with mysql in docker-compose
  13. 高并发架构技术|缓存失效、缓存穿透问题 PHP 代码解决
  14. 电脑不能使用ArcMap 提示由于系统时间不对造成的怎么办?转
  15. Distributed systems theory for the distributed systems engineer
  16. 51NOD 1081 子段求和
  17. HDU-4471 Yet Another Multiple Problem (BFS+路径还原)
  18. libevent 简单学习
  19. Qt 编程指南
  20. Search for a Range——稍微升级版的二分查找

热门文章

  1. 用python绘制漂亮的图形
  2. Ubuntu中修改默认开机项
  3. 配置多个JDK存在的问题与解决方案 (亲测可用)
  4. 自己动手写Spring框架--IOC、MVC
  5. 5、数组的复制(test2.java、test3.java)
  6. JSP前端数据本地排序
  7. 60701BMP彩色图像转化为灰度及二值图像
  8. .net core + mvc 手撸一个代码生成器
  9. C#串口类封装 SuperSerialPort
  10. 本地在不安装Oracle的情况下安装PLSQL客户端