Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17336    Accepted Submission(s): 5701

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.



Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).



Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).



But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.

Process to the end of file.
 
Output
Output the maximal summation described above in one line.
 
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
 
Sample Output
6
8
Hint
Huge input, scanf and dynamic programming is recommended.

给定一个数组,求M段连续的子段和最大。dp[i][j]表示前i段选择第j个元素的最优解。

dp[i][j]=max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j

由于k<j,所以我们能够用两个一维数组,一个dp[i]记录当前行状态。一个d[i]记录下一行可选的最大值。

用64位会超时。但int能水过。。

</pre><pre name="code" class="cpp">/*
dp[i][j]=max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
第j个元素选i段区间,对于当前元素a[j],能够把它接到第i段的第j-1位置构成一段。
或者单独成一段。 观察这个方程。对于dp[i][j-1]这一项,它和dp[i][j]同i,就是在一段。
用一维数组就能记录;
dp[i-1][k]是i-1段j位置前能取的最大值。我们能够在计算当前第i段时,
把dp[i-1][k]记录下来,取最大值就好了。
*/ #include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define ll __int64
const int inf=0x7fffffff;
#define N 1000010
int a[N];
int pre[N]; //即dp[i-1][k]。记录j位置前可选值
int dp[N];
int main()
{
int i,j,n,m;
int tmp,ans;
while(~scanf("%d%d",&m,&n))
{
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
dp[i]=0;
pre[i]=0;
}
pre[0]=dp[0]=0;
ans=-inf;
for(i=1;i<=m;i++)
{
tmp=-inf;
for(j=i;j<=n;j++)
{
dp[j]=max(dp[j-1]+a[j],pre[j-1]+a[j]);
pre[j-1]=tmp; //tmp记录的是当前段j位置的最大值,
tmp=max(tmp,dp[j]);//而数组pre[]是记录j-1位置的,所以要先取tmp,再更新tmp
}
}
for(i=m;i<=n;i++)
ans=max(ans,dp[i]);
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. JavaScript Patterns 5.7 Object Constants
  2. uestc 1073 秋实大哥与线段树 Label:线段树
  3. Erlang进程的Link机制
  4. (转)面试题--JAVA中静态块、静态变量加载顺序详解
  5. STL MAP及字典树在关键字统计中的性能分析
  6. 【原创】利用C++ RAII技术自动回收堆内存
  7. MFC实现数独(2)
  8. Asp.Net MVC Ajax
  9. 巧妙使用Contains()方法查找一个数是否在某堆数中
  10. Alamofire源码解读系列(十一)之多表单(MultipartFormData)
  11. 关于javascript在OJ系统上编程的注意事项
  12. 007-declare 声明变量的类型
  13. 怎么隐藏 iOS Safari 打开网页时的地址栏和工具栏探索
  14. 各种“地”—— 各种“GND”
  15. JSON序列——根据JSON生成事务性SQL
  16. MySQL用户管理、常用sql语句、MySQL数据库备份恢复
  17. Angular build Error:In this configuration Angular requires Zone.js
  18. 在HTML代码中要如何插入空格?
  19. Mysql 批量插入数据的方法
  20. 关联规则之Apriori

热门文章

  1. js 获取json数组里面数组的长度
  2. Python之Pandas中Series、DataFrame实践
  3. opencv 检测图片中圆形物体(解决乱线问题)
  4. NX自动出图
  5. Angular——自定义服务
  6. C# 创建与读写配置文件
  7. 26-Ubuntu-文件和目录命令-其他命令-管道
  8. python logger日志
  9. 我的MYSQL学习心得链接
  10. [POJ1155]TELE(树形背包dp)