Time Limit: 1000MS
Memory Limit: 32768KB
64bit IO Format: %I64d & %I64u

SubmitStatus

Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.

There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:

(1) Mark a vertex in the graph.

(2) Find the shortest-path between two vertices only through marked vertices.

For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets
problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.

Could you also solve the shortest-path problem?

 

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000;
and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y),
and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There
is a blank line between two consecutive test cases.

End of input is indicated by a line containing N = M = Q = 0.
 

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.

For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.

For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.

There is a blank line between two consecutive test cases.
 

Sample Input

5 10 10
1 2 6335
0 4 5725
3 3 6963
4 0 8146
1 2 9962
1 0 1943
2 1 2392
4 2 154
2 2 7422
1 3 9896
0 1
0 3
0 2
0 4
0 4
0 1
1 3 3
1 1 1
0 3
0 4
0 0 0
 

Sample Output

Case 1:
ERROR! At point 4
ERROR! At point 1
0
0
ERROR! At point 3
ERROR! At point 4
 

Source

2010 Asia Regional Tianjin Site ―― Online Contest



题意:有向图,有重边。选中一些点。在这些点里面求两点的最短路。有2个操作,操作 "0" 表示标记 x 选中,假设x之前已经被选中。输出 "ERROR! At point x"。操作 "1" 表示求 x ->y 的最短路。假设x或y不在选中的点里面。输出 "ERROR! At path x to y"。假设有不存在则输出 "No such path"。



思路:初始化 vis 数组为-1,表示所有未被选中。之后标记 vis[x] 为0表示 x 被选中。更新Floyd。把 x 点作为中间点更新最短路数组。

<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std; #define ll long long
const ll INF = 1<<30;
const double PI = acos(-1.0);
const double e = 2.718281828459;
const double eps = 1e-8;
int n, m, t;
const int MAXN = 310;
ll g[MAXN][MAXN];
int vis[MAXN]; void Floyd(int k)
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(g[i][j] > g[i][k]+g[k][j])
g[i][j] = g[i][k]+g[k][j];
}
}
} int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int num = 1;
while(cin>>n>>m>>t)
{
if(!n && !m && !t)
break;
memset(vis, -1, sizeof(vis));
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
g[i][j] = (i==j)?0:INF;
}
}
//cout<<g[4][5]<<endl;
int p, q, x, y;
ll w;
for(int i = 1; i <= m; i++)
{
scanf("%d %d %I64d", &p, &q, &w);
if(g[p][q] > w)
g[p][q] = w;
}
if(num != 1)
printf("\n");
printf("Case %d:\n", num++);
while(t--)
{
scanf("%d", &q);
if(q == 0)
{
scanf("%d", &x);
if(vis[x] == 0)
printf("ERROR! At point %d\n", x);
else
{
vis[x] = 0;
Floyd(x);
}
}
else
{
scanf("%d %d", &x, &y);
if(vis[x]==-1 || vis[y]==-1)
printf("ERROR! At path %d to %d\n", x, y);
else
{
if(g[x][y] != INF)
printf("%I64d\n", g[x][y]);
else
printf("No such path\n");
}
}
}
}
return 0;
} </span>

最新文章

  1. 关于Map集合
  2. mysql与oracle的日期/时间函数小结
  3. android canvas d
  4. StringGrid 实例4 本例功能: 1、给每个单元格赋值 2、调整当前单元格位置:上下左右;
  5. swift文件上传及表单提交
  6. Android之自定义生成彩色二维码
  7. eclipse 新建 maven 项目 步骤(初级入门新手)
  8. centos6.5网络配置问题:ping不通
  9. 如何在KVM中管理存储池
  10. hbase总结:如何监控region的性能
  11. Spark-Java版本WordCount示例
  12. Notepad++ 配置 支持jquery、html、css、javascript、php代码提示
  13. 对象池化技术 org.apache.commons.pool
  14. 转 精选37条强大的常用linux shell命令组合
  15. [js高手之路]Vue2.0基于vue-cli+webpack父子组件通信教程
  16. 2017-11-11 Sa Oct Is it online
  17. tensorflow中文教程
  18. [模板][P3803]多项式乘法
  19. 第一个SpringBoot应用
  20. 由Windows开发平台向Linux平台转移的一些想法

热门文章

  1. 【Python-2.7】删除空格
  2. MySQL 8.*版本 修改root密码
  3. 没搞错吧,我只是个web前端工程师,不是manager,也不是leader...
  4. Java Servlet DAO实践(二)
  5. 当From窗体中数据变化时,使用代码获取数据库中的数据然后加入combobox中并且从数据库中取得最后的结果
  6. CAD使用SetxDataLong写数据(网页版)
  7. tf idf公式及sklearn中TfidfVectorizer
  8. 社交网络图中结点的“重要性”计算 (30 分) C++解法
  9. Spring Boot 与任务
  10. 版本优化-test