pid=4932">Miaomiao's Geometry

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/65536 K (Java/Others)

Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.



There are 2 limits:



1.A point is convered if there is a segments T , the point is the left end or the right end of T.

2.The length of the intersection of any two segments equals zero.



For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn't equals zero), [1 , 3] and [3 , 4]
are not(not the same length).



Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.



For your information , the point can't coincidently at the same position.
 
Input
There are several test cases.

There is a number T ( T <= 50 ) on the first line which shows the number of test cases.

For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.

On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 
Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 
Sample Input
3
3
1 2 3
3
1 2 4
4
1 9 100 10
 
Sample Output
1.000
2.000
8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1.
For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2.
For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
 
题意:给出n个点,找出一些等长的线段覆盖这些点。这些点仅仅能作为线段的端点,并且随意两条线段的相交长度不能大于0.求满足条件的线段的最大长度。
分析:通过分析能够得出。终于结果是相邻两点之间的长度,或者相邻两点之间长度的一半。由于最多仅仅有50个点,100个长度,所以仅仅需枚举这些长度。求出一个满足条件的最长线段就可以。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
double b[120], c[60];
int flag[60];
int n, i, j, T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i = 0; i < n; i++)
scanf("%lf",&c[i]);
sort(c, c+n);
int m = 0;
for(i = 1; i < n; i++)
{
b[m++] = c[i] - c[i-1];
b[m++] = (c[i] - c[i-1]) / 2;
}
sort(b, b+m);
double ans;
for(i = m - 1; i >= 0; i--)
{
memset(flag, 0, sizeof(flag));
flag[0] = 1;
double tmp = b[i];
for(j = 1; j < n - 1; j++)
{
if(c[j] - tmp < c[j-1] && c[j] + tmp > c[j+1]) //往左往右都不行
break;
if(c[j] - tmp >= c[j-1])
{
if(flag[j-1] == 2) // 前一个往右
{
if(c[j] - c[j-1] == tmp) flag[j] = 1; //两个点作为线段的两个端点
else if(c[j] - c[j-1] >= 2 * tmp) flag[j] = 1; //一个往左。一个往右
else if(c[j] + tmp <= c[j+1]) flag[j] = 2; //仅仅能往右
else break;
}
else flag[j] = 1;
}
else if(c[j] + tmp <= c[j+1])
flag[j] = 2;
}
if(j == n - 1)
{
ans = tmp;
break;
}
}
printf("%.3lf\n", double(ans));
}
return 0;
}

最新文章

  1. CodeSmith模板代码生成实战详解
  2. VPN添加静态路由表(指定程序或资源走VPN)
  3. Launch Screen在iOS7/8中的实现
  4. knockoutjs foreach array绑定 表格 下拉框绑定
  5. TCL随记(1)
  6. 使用DS18B20设计温控系统
  7. printf 格式化最常用用法
  8. python进度条代码
  9. SPI通信
  10. SettingsProvider该CRUD
  11. vs2012+Spring.Core.dll
  12. 【转】Java 并发:Executors 和线程池
  13. Kubernetes系列02—Kubernetes设计架构和设计理念
  14. k8s重启策略
  15. 旅行,说走就走 Help? [C++数据类型和表达式]
  16. c3p0链接池配置使用
  17. 洛谷 P2292 [HNOI2004] L语言 解题报告
  18. dijkstra优化
  19. 学习笔记之Python调试 - pdb
  20. 数位dp——奏响数字数位的美妙乐章

热门文章

  1. Windows键盘驱动结构与消息机制--转
  2. html5——web存储
  3. JS——scroll封装
  4. [Windows Server 2012] 手工破解MySQL密码
  5. CSS3:变换和动画
  6. Ajax无刷新显示
  7. Please, commit your changes or stash them before you can merge
  8. Mirror用法
  9. ImageMagick的下载和配置
  10. 北京Python开发培训怎么选?