Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e l
l r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e d
l l
lowor

分析

由题可得1:2*n1+n2=N+2;
2:n1<=n2;
3:3<=n2<=N;
由1,3可得 n2>=(N+2)/3,再由1计算出n1
所以 n2 等于最小的大于等于(N+2)/3的整数,但是如果计算出n1,n2不是整数的话(即 N+2-n2 不是偶数的话),就把n2+1,在算出n1;
至于输出格式的控制,可以先输出n1-1行(先输出s[i],在输出n2-2个空格,再输出s[s.size()-1-i]),然后输出剩余的底部就行了。
#include<iostream>
#include<math.h>
using namespace std;
int main(){
string s;
cin>>s;
int n1,n2,n3;
n2=ceil((s.size()+2)/3.0);
n2=(s.size()+2-n2)%2>0?n2+1:n2;
n1=(s.size()+2-n2)/2;
for(int i=0;i<n1-1;i++){
cout<<s[i];
for(int j=0;j<n2-2;j++)
cout<<" ";
cout<<s[s.size()-i-1]<<endl;
}
for(int i=n1-1;i<n1-1+n2;i++)
cout<<s[i];
return 0;
}

最新文章

  1. Oracle建表
  2. 使用JUnit4测试Spring
  3. hdu A计划
  4. 在Runbook中添加Checkpoint-workflow
  5. 从MySQL到Redis 提升数据迁移的效率
  6. 互联网+医疗(FW)
  7. 提升 DevOps 效率,试试 ChatOps 吧!
  8. 启动Tomcat一闪而过解决
  9. Linux 挂载光驱
  10. 并发编程: c++11 thread(Func, Args...)利用类成员函数创建线程
  11. php 文件夹遍历俩种对比
  12. HighCharts之2D带Label的折线图
  13. Dialog样式的Activity
  14. 预测氨基酸替换的致病性及分子机制:MutPred工具的使用
  15. (转)以太坊(Ethereum ETH)的奖励机制
  16. Android APK 签名比对(转)
  17. 使用Maven对JAVA程序打包-带主类、带依赖【转】
  18. mysql免安装版本(用批处理安装和启动)
  19. Idea软件Vim插件问题
  20. Eclipse错误笔记!

热门文章

  1. nginx - ubutun下安装nginx(详述编译方法)
  2. E20171214-sl
  3. [App Store Connect帮助]六、测试 Beta 版本(3.1)管理测试员:添加内部测试员
  4. Akka源码分析-Akka-Streams-GraphStage
  5. 最大化最小值poj2456Aggressive cows
  6. docker血一样的教训,生成容器的时候一定要设置数据卷,把数据文件目录,配置文件目录,日志文件目录都要映射到宿主机上保存啊!!!
  7. EditText(6)EditText的子类
  8. 百度地图API显示多个标注点带提示的代码 / 单个标注点带提示代码
  9. TCP流量控制与拥塞解决
  10. Apache JServ protocol服务 怎么关闭?