Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 22742    Accepted Submission(s): 9865


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input

2
100
-4
 

Sample Output

1.6152
No solution!

二分求解

#include<stdio.h>
const double eps = 1e-8;//精度大胆设高些 double cal(double x,double y)
{
double m;
m = 8 * x*x*x*x + 7 * x*x*x + 2 * x*x + 3 * x + 6 - y;
return m;
} double bsearch(double y)
{
double left = 0, right = 100;
double mid;
while (right - left > eps)
{
mid = (left + right) / 2;
if (cal(mid, y)>0)
{
right = mid;
}
else
{
left = mid;
}
}
return mid;
} int main()
{
int T;
scanf("%d", &T);
double M,n;
while (T--)
{
scanf("%lf", &M);
if (M < 6 || M>807020306)//注意上下界
{
printf("No solution!\n");
}
else
{
n=bsearch(M);
printf("%.4lf\n", n);
}
}
return 0;
}

最新文章

  1. CDH离线数据导入solr:利用MapReduceIndexerTool将json文件批量导入到solr
  2. Javascript学习记录——数组去重
  3. Web API 接口
  4. Memcached深度分析
  5. select根据text选择项与select其它操作
  6. Find Query Window的运作(手电筒)
  7. linux --备份oracle
  8. BZOJ 4247 挂饰 背包DP
  9. 设计一个算法,输出从u到v的全部最短路径(採用邻接表存储)
  10. Java多线程概述
  11. DotNet中的计时器线程计时器
  12. $rootScope
  13. C#实战Microsoft Messaging Queue(MSMQ)
  14. 谈谈MySQL的事务隔离级别
  15. Pat1108: Finding Average
  16. 安装webstrom2019
  17. 移动端弹出层加遮罩后禁止body滑动
  18. C#基础:委托之Action&lt;T&gt;和Func&lt;T&gt;的用法
  19. gcd最大生成树模板
  20. s2 Docker环境的快速搭建方法

热门文章

  1. angularJS 控制输入的百分数在0%-100%之间
  2. 简明python教程笔记
  3. 【简记】前端对接WebSocket与心跳重连
  4. shell学习1---基本的shell命令
  5. Java写的数据库连接池
  6. 腾讯高级设计师谈微信的旧容与新妆,Android Design是大势所趋
  7. centos6安装elasticsearch6.0
  8. exec操作文件描述符
  9. InnoDB 引擎独立表空间
  10. 在window 8 或windows2012 上用命令行安装framework3.5 方法