Problem A.Ant on a Chessboard

Background

One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.

For example, her first 25 seconds went like this:

( the numbers in the grids stands for the time when she went into the grids)

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

Input

Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

Output

For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

Sample Input

8

20

25

0

Sample Output

2 3

5 4

1 5

#include<stdio.h>
#include<math.h>
int main(void)
{
int n;
while(scanf("%d",&n)&&n)
{
int x=0,y=0;
int p=sqrt((double)n);
if(p*p==n&&p%2) {x=1;y=p;}
else if(p*p==n&&p%2==0){x=p;y=1;}
else if(p%2==0&&n!=p*p) {
if(n-p-1<=p*p){x=p+1;y=n-p*p;}
else{x=p-(n-1-p-p*p)+1;y=p+1;}
}
else if(p%2==1&&n!=p*p) {
if(n-p-1<=p*p){x=n-p*p;y=p+1;}
else{x=p+1;y=p-(n-1-p-p*p)+1;}
}
printf("%d %d\n",x,y);
}
return 0;
}

最新文章

  1. MFC如何读取XML
  2. MS SQL 错误:无法绑定由多个部分组成的标识符 &quot;xxxxx&quot;
  3. Redis教程(一):Redis简介
  4. Html 之菜单导航(二)
  5. UDP模式聊天
  6. LeetCode Flatten 2D Vector
  7. is_file和file_exists效率比较
  8. 解决Xcode7 iOS9苹果将原http协议改成了https协议问题
  9. poj 3190 Stall Reservations 贪心 + 优先队列
  10. Weka算法介绍
  11. $.ajax的一些坑啊
  12. 【XSY2843】「地底蔷薇」 NTT什么的 扩展拉格朗日反演
  13. 【译】第八篇 SQL Server安全数据加密
  14. Atitit 大json文件的结构化查看解决方案,高性能的jsonview &#160;attilax总结.docx
  15. Spring_错误 java.sql.SQLException: Lock wait timeout exceeded | CannotAcquireLockException 的解决
  16. 《Go语言实战》摘录:7.3 并发模式 - work
  17. Visual Studio 2010 Express for Windows Phone 永久免费序列号
  18. Harbor 学习分享系列4 - Harbor常用功能实验
  19. Java_基础知识回顾
  20. jqGrid使用json实现的范例一

热门文章

  1. NM常用网络命令
  2. AngularJS学习笔记(一)——一些基本知识
  3. zoj 3665 数论 二分法 两个参数
  4. 三个创建WebStorm项目的方法
  5. python网络爬虫进入(一)——简单的博客爬行动物
  6. attr与prop的区别
  7. 运行jar包
  8. Yeoman入门之安装及环境配置
  9. Roslyn 编译平台概述
  10. 解决C# WinForm 中 VSHOST.EXE 程序不关闭的问题