单调栈: 维护一个单调栈

A Famous City

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1671    Accepted Submission(s): 644

Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:

- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building,
or no buildings at all.

- measure the height of each building in that piece.

- write a program to calculate the minimum number of buildings.

Mr. B has finished the first two steps, the last comes to you.
 
Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the
input numbers will be nonnegative and less than 1,000,000,000.
 
Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 
Sample Input
3
1 2 3
3
1 2 1
 
Sample Output
Case 1: 3
Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
 
Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <stack> using namespace std; stack<int> stk;
int n; int main()
{
int cas=1;
while(scanf("%d",&n)!=EOF)
{
int ans=0;
while(!stk.empty()) stk.pop();
for(int i=0;i<n;i++)
{
int x;
scanf("%d",&x);
if(stk.empty())
{
if(x!=0) stk.push(x);
continue;
}
if(stk.top()==x) continue;
else if(stk.top()<x) stk.push(x);
else
{
bool flag=true;
while(!stk.empty())
{
if(stk.top()>x)
{
stk.pop(); ans++;
}
else if(stk.top()==x)
{
flag=false;
break;
}
else if(stk.top()<x)
{
if(x!=0) stk.push(x);
flag=false;
break;
}
}
if(flag)
{
if(x!=0) stk.push(x);
}
}
}
ans+=stk.size();
printf("Case %d: %d\n",cas++,ans);
}
return 0;
}

最新文章

  1. [转]Ubuntu 12.04中文输入法的安装
  2. php学习
  3. [转] 基于MySQL的秒杀核心设计(减库存部分)-防超卖与高并发
  4. Five More Hacker Tools Every CISO Should Understand
  5. MongoDB开发学习
  6. Android弹出选项框及指示箭头动画选择
  7. JavaWeb项目开发案例精粹-第4章博客网站系统-001设计
  8. css实现鼠标经过导航文字偏位效果
  9. Extjs combox的详解
  10. spoj 839 Optimal Marks(二进制位,最小割)
  11. [学习笔记]设计模式之Composite
  12. WP独立文件资源字典
  13. KEIL的ARM编译器对RW和ZI段的一个处理
  14. openstack第1天
  15. 返璞归真 asp.net mvc (9) - asp.net mvc 3.0 新特性之 View(Razor)
  16. java regex possissive relunctant
  17. Linux安装mysql-5.7.17
  18. Hbuilder之开发Python
  19. Mysql Navicat数据库定时备份,定时删除
  20. hdoj:2053

热门文章

  1. 三篇编译libcurl,附下载 good
  2. C++临时对象销毁时间
  3. Delphi Jpg和Gif转Bmp
  4. SQL Server带游标的SQL
  5. auto, extern, register, static
  6. req.xhr在express中的应用
  7. wx.button
  8. Ubuntu12.04下eclipse提示框黑色背景色的修改方法
  9. 【邻接表字符串Hash】【HDU1800】Flying to the Mars
  10. Java基础学习笔记1