Time Limit:1000MS     Memory Limit:32768KB

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

以下是代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <map>//使用字典容器
#include <string>
using namespace std;
int main(){
int n,k,cnt[1005];
char str[100];
string t;
while(scanf("%d",&n)!=EOF && n){
map<string,int>ball;
map<string, int>::iterator it;
k=1;
for(int i=0;i<1005;cnt[i]=1,i++);
for(int i=0;i<n;i++){
scanf("%s",str);
t = str;
if(ball.count(t))cnt[ball[t]]++;//存在,数量加一
else ball[t]=k++;//不存在,将颜色映射为数字
}
int maxn=1;
for(int i=2;i<n;i++)
if(cnt[i]>cnt[maxn])maxn=i;
for(it = ball.begin();it!=ball.end();it++)
if(it->second == maxn){
cout << it->first<<endl;
break;
}
ball.clear();
}
}

  

最新文章

  1. H5案例分享:使用JS判断客户端、浏览器、操作系统类型
  2. unity-点乘和叉乘的应用
  3. 每天一个linux命令(34):du 命令
  4. Ahead-of-time compilation(AOT)
  5. django 1.5+ 权限设计浅析
  6. spring的初始化bean,销毁bean之前的操作详解
  7. datagrid中load,reload,loadData方法的区别
  8. Android核心分析 之九Zygote Service
  9. [原创]一种Unity2D多分辨率屏幕适配方案
  10. [转载]C#图片格式(JPG,BMP,PNG,GIF)等转换为ICO图标
  11. Java解析XML文档(简单实例)&mdash;&mdash;dom解析xml
  12. Android Permission denied 错误 ( 附Android权限大全 )
  13. 办理西蒙弗雷泽大学(本科)学历认证『微信171922772』SFU学位证成绩单使馆认证Simon Fraser University
  14. ubuntu 连接VPN 命令
  15. SQLServer中间接实现函数索引或者Hash索引
  16. mysql的压缩特性-需求
  17. 《css定位 position》课程笔记
  18. Android缓存机制——LruCache
  19. Objective-C代码简写
  20. Java多线程(四)—— synchronized关键字续

热门文章

  1. 目标检测YOLO算法-学习笔记
  2. hdu 2918(IDA*)
  3. python3----练习题(爬取电影天堂资源,大学排名,淘宝商品比价)
  4. Android 蓝牙学习
  5. vue 二级列表折叠面板
  6. 巨蟒python全栈开发-第11阶段 devops-git入门1
  7. HDU_5527_Too Rich
  8. Content-Negotiation Header Quality Values
  9. disable的错误使用
  10. VI乱码, cat 和 more正常