Ignatius and the Princess IV

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32767K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.



"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.



"But what is the characteristic of the special integer?" Ignatius asks.



"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.



Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the
N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

Author

Ignatius.L

解题思路:

给出n个数。n为奇数。求在里面至少出现(n+1)/2 次的那个数。

方法一:

同等消除。比方数 -1 -2  3 3 3 -2 ,消除一次-1 3 -2 去掉。剩余3 3 -2 。再消除一次 剩余3,3就是所求。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std; int main()
{
int n;
int num,cnt,r;
while(scanf("%d",&n)!=EOF)//一定得写上。EOF
{
cnt=0;
while(n--)
{
scanf("%d",&num);
if(cnt==0)
{
r=num;
cnt=1;
}
if(num==r)
cnt++;
else
cnt--; }
printf("%d\n",r);
}
return 0;
}

方法二:hash打表。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000005;
int hash[maxn]; int main()
{
int n,num,r;
while(scanf("%d",&n)!=EOF)
{
memset(hash,0,sizeof(hash));
for(int i=1;i<=n;i++)
{
scanf("%d",&num);
hash[num]++;
if(hash[num]>n/2)
{
r=num;//找到了也不能break掉。由于有可能还没有输入完成
}
}
printf("%d\n",r);
}
return 0;
}

最新文章

  1. CodeForces445A DZY Loves Chessboard
  2. Eclipse创建maven项目
  3. ECharts – 大数据时代,重新定义数据图表
  4. PLSQL看oracle中汉字显示乱码
  5. java基础-操作符
  6. andriod学习之一
  7. Mysql 允许null 与 default值
  8. [Linux]Nginx + Node.js + PM2 + MongoDb + (Memcached) Part I
  9. 使用C# 实现文件锁
  10. 不实名认证去除新浪云SEA的实名认证提示的方法
  11. mvc action 参数绑定——值提供器【学习笔记】
  12. ZOJ3574(归并排序求逆数对)
  13. jQuery获取Select选择的Text(非表单元素)和 Value(表单元素)(转)
  14. Tomcat集群+Nginx+Redis服务搭建
  15. java.lang.IllegalAccessError: tried to access method com.google.common.base.Stopwatch.&lt;init&gt;()V from 解决
  16. Servlet学习三:不允许直接访问jsp处理方式一过滤器
  17. 【Android Developers Training】 74. 序言:通过无线连接设备
  18. 分页查询时,使用cookie保存上次的查询条件。jQuery实现方法以及中间遇到的坑
  19. 洛谷 P1146 【硬币翻转】题解
  20. axios delete请求 参数

热门文章

  1. cf 512D - Fox And Travelling
  2. sql2008百万级数据排除重复信息
  3. 博客移至CSDN
  4. CodeForces Round #402 (Div.2) A-E
  5. Codeforces Round #453 Div. 2 A B C D (暂时)
  6. Python学习杂记_5_列表常用操作
  7. java通过读取本地文件获取反射方法参数,执行对象方法
  8. function in Postgres
  9. HDU 1024 Max Sum Plus Plus [动态规划+m子段和的最大值]
  10. Codeforces 583 DIV2 Robot&#39;s Task 贪心