题目链接

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.

For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)

Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2

3 2

1 2 1

2 3 1

3 3

1 2 1

2 3 1

1 3 1
Sample Output

Case 1: 1
Case 2: 2

模板题,用来测试模板,我的模板都能过。

#include<cstdio>
#include<cstring>
#include<queue>
#define INF 1e9
using namespace std;
const int maxn=200+5; struct Edge
{
int from,to,cap,flow;
Edge() {}
Edge(int f,int t,int c,int flow):from(f),to(t),cap(c),flow(flow) {}
}; struct Dinic
{
int n,m,s,t;
vector<Edge> edges;
vector<int> G[maxn];
bool vis[maxn];
int cur[maxn];
int d[maxn]; void init(int n,int s,int t)
{
this->n=n, this->s=s, this->t=t;
edges.clear();
for(int i=1; i<=n; i++)
G[i].clear();
} void AddEdge(int from,int to,int cap)
{
edges.push_back(Edge(from,to,cap,0));
edges.push_back(Edge(to,from,0,0));
m = edges.size();
G[from].push_back(m-2);
G[to].push_back(m-1);
} bool BFS()
{
memset(vis,0,sizeof(vis));
queue<int> Q;
d[s]=0;
Q.push(s);
vis[s]=true;
while(!Q.empty())
{
int x=Q.front();
Q.pop();
for(int i=0; i<G[x].size(); i++)
{
Edge& e=edges[G[x][i]];
if(!vis[e.to] && e.cap>e.flow)
{
vis[e.to]=true;
Q.push(e.to);
d[e.to]= 1+d[x];
}
}
}
return vis[t];
} int DFS(int x,int a)
{
if(x==t || a==0)
return a;
int flow=0,f;
for(int& i=cur[x]; i<G[x].size(); i++)
{
Edge& e=edges[G[x][i]];
if(d[x]+1==d[e.to] && (f=DFS(e.to,min(a,e.cap-e.flow) ))>0 )
{
e.flow+=f;
edges[G[x][i]^1].flow -=f;
flow+=f;
a-=f;
if(a==0)
break;
}
}
return flow;
} int Maxflow()
{
int flow=0;
while(BFS())
{
memset(cur,0,sizeof(cur));
flow += DFS(s,INF);
}
return flow;
}
} DC; int main()
{
int n,m,t;
scanf("%d",&t);
for(int i=1;i<=t;++i)
{
scanf("%d%d",&n,&m);
DC.init(n,1,n);
while(m--)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
DC.AddEdge(u,v,w);
}
printf("Case %d: %d\n",i,DC.Maxflow());
}
return 0;
}

最新文章

  1. Php:学习笔记(一):版本选择
  2. ajax下载文件
  3. TCP SYN扫描学习笔记
  4. Hibernate学习-在线书城后台管理系统的设计
  5. 玩转Java对象和XML相互转换
  6. js跳转页面方法大全
  7. PHP学习笔记四【类型运算】
  8. 【第四篇】androidEventbus源代码阅读和分析
  9. MFC下对串口的操作以及定时器的调用
  10. [转载] Storm:最火的流式处理框架
  11. jQuery结合lhgdialog弹出窗口,关闭时出现没有权限错误
  12. var、let 及 const 区别
  13. 针对 jQuery Gridly 控件显示多少列的问题。
  14. 在admui中怎样上传本地文件?
  15. 第三十节,目标检测算法之Fast R-CNN算法详解
  16. oracle 12C版本的下载安装
  17. 利用PHP连接数据库——实现用户数据的增删改查的整体操作实例
  18. 最长k可重区间集问题&amp;&amp;最长k可重线段集问题
  19. OpenCV 填充(ROI)+模糊操作
  20. Eclipse添加git插件上传项目到github

热门文章

  1. spring使用jdbc
  2. docker、docker-compose安装,卸载
  3. web系统安全运营之基础- 基于DFA算法的高性能的敏感词,脏词的检测过滤算法类(c#).
  4. 一、VMware Workstation 15中文破解版 下载与安装(附密钥)
  5. 经常使用到的vim命令
  6. 在java 中一种简单方式的声明静态Map常量的方法
  7. stand up meeting 12/01/2015
  8. HBase BucketAllocatorException 异常剖析
  9. 详解 Map集合
  10. 4. git log的常见用法