Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15989   Accepted: 7303

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road irequires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

求目标点到图中的其他点来回的最小值。

Dijkstra直接求来回的距离,然后比较求出最小值。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; const int MAX = 100005;
int edge[1005][1005];
int vist[1005],vist2[1005],minidis1[1005][1005],minidis2[1005][1005];
int N,M,X; void init()
{
int i,j; for(i=1;i<=N;i++)
{
for(j=1;j<=N;j++)
{
if(j==i)
{
edge[i][j]=0;
minidis1[i][j]=0;
minidis2[i][j]=0;
}
else
{
edge[i][j]=-1;
minidis1[i][j]=MAX;
minidis2[i][j]=MAX;
}
}
}
for(i=1;i<=N;i++)
{
vist[i]=0;
vist2[i]=0;
}
} void dijkstra(int i)
{
int j,k;
int position=i;
int position2=i; vist[position]=1;
vist2[position]=1;
minidis1[i][position]=0;
minidis2[position][i]=0; for(j=1;j<=N-1;j++)//一共要添加进num-1个点
{
for(k=1;k<=N;k++)
{
if(vist[k]==0 && edge[position][k]!=-1 && minidis1[i][position]+edge[position][k] < minidis1[i][k])//新填入的点更新minidis
{
minidis1[i][k]=minidis1[i][position]+edge[position][k];
}
if(vist2[k]==0 && edge[k][position2]!=-1 && minidis2[position2][i]+edge[k][position2] < minidis2[k][i])//新填入的点更新minidis
{
minidis2[k][i]=minidis2[position2][i]+edge[k][position2];
}
}
int min_value=MAX,min_pos=0;
int min_value2=MAX,min_pos2=0;
for(k=1;k<=N;k++)
{
if(vist[k]==0 && minidis1[i][k]<min_value)//比较出最小的那一个作为新添入的店
{
min_value = minidis1[i][k];
min_pos = k;
}
if(vist2[k]==0 && minidis2[k][i]<min_value2)//比较出最小的那一个作为新添入的店
{
min_value2 = minidis2[k][i];
min_pos2 = k;
}
} vist[min_pos]=1;
position=min_pos; vist2[min_pos2]=1;
position2=min_pos2;
} } int main()
{
int i;
cin>>N>>M>>X;
init(); int temp1,temp2,temp3;
for(i=1;i<=M;i++)
{
cin>>temp1>>temp2>>temp3;
edge[temp1][temp2]=temp3;
}
memset(vist,0,sizeof(vist));
memset(vist2,0,sizeof(vist2)); dijkstra(X);
int ans=-1;
for(i=1;i<=N;i++)
{
if(i==X)continue;
ans=max(ans,minidis1[X][i]+minidis2[i][X]);
} cout<<ans<<endl;
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Windows 上的 Jetty 小工具
  2. 12套swift学习资源分享
  3. Linux中的两种守护进程stand alone和xinetd
  4. game of life
  5. Sql server cast(as nvarchar) 默认长度问题
  6. jQuery 源码基本框架
  7. mongDB 的使用
  8. ASSERT_VALID和ASSERT宏分析
  9. 数学函数类方法的使用.java
  10. UVA10817--状态压缩DP
  11. MySQL必知必会笔记&lt;2&gt;
  12. 新服务器部署sqlserver之前的准备
  13. Struts2学习笔记(一)——环境搭建
  14. 什么是HTTP Referer?
  15. iOS----------面试常问
  16. C#学习-扩展方法
  17. 使用ibatis时 sql中 in 的参数赋值(转)
  18. Oracle_PL/SQL(4) 过程和函数
  19. [Alg::DP] 袋鼠过河
  20. Web - TCP的三次握手

热门文章

  1. windows网络编程-C语言实现简单的TCP协议聊天
  2. Jquery 动态交换两个div位置并添加Css动画效果
  3. login() got an unexpected keyword argument &#39;extra_context&#39;
  4. 简单优化MySQL(后续在补充)
  5. mybatis 多参数传递
  6. Python学习第十二课——json&amp;pickle&amp;XML模块&amp;OS模块
  7. Codeforces Round #594 (Div. 2) - C. Ivan the Fool and the Probability Theory(思维)
  8. centos7中redis安装
  9. Android Studio中 no module 问题,解决方法
  10. 【剑指Offer面试编程题】题目1523:从上往下打印二叉树--九度OJ