Packets
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48349   Accepted: 16392

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

Source

很不错的一道题目,贪心的话就不讲了,先放大的,再放小的,刚开始我是分过程一个一个模拟的,也就是在当前情况下再分子情况讨论,,有些繁琐,当然更容易错,看了下大牛的博客,,zzz,瞬间膜拜,上代码
<span style="font-size:32px;">#include <iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int a[8],u[4]={0,5,3,1};
int main()
{
while(~scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
{
if(!a[1]&&!a[2]&&!a[3]&&!a[4]&&!a[5]&&!a[6])
return 0;
int cnt=a[6]+a[5]+a[4]+(a[3]+3)/4;/*先装好能“独当一面的”大快 递物品,初步确定至少要的箱子数目/
int t2=a[4]*5+u[a[3]%4];/*确定好再上一行代码的情况下,能额外放 入2*2物品的数目*/
if(a[2]>t2)
cnt+=(a[2]-t2+8)/9;/*需要为a[2]单独再开箱子*/
int t1=cnt*36-a[6]*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;/*补a[1]*/
if(a[1]>t1)
cnt+=(a[1]-t1+35)/36;
printf("%d\n",cnt);
}
return 0;
}
</span>

最后附上本人起初写的wrong
answe代码,一步一步暴力。。

再度膜拜大牛
#include <iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int a[8];
int main()
{
while(~scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
{
if(a[1]+a[2]+a[3]+a[4]+a[5]+a[6]==0)
return 0;
int cnt=a[6]+a[5]+a[4];
a[1]-=a[5]*11;
a[2]-=a[4]*5;
int t3=(a[3]-1+4)/4;
cnt+=t3;
if(a[3]%4!=0)
{
int yu=4-a[3]%4;
if(yu==3)
{
if(a[2]>0)
if(a[2]>=5)
{
a[2]-=5;
a[1]-=7;
}
else
{
a[1]-=27-a[2]*4;
a[2]=0;
}
}
else if(yu==2)
{
if(a[2]>0)
if(a[2]>=3)
{
a[2]-=3;
a[1]-=6;
}
else
{
a[1]-=12-a[2]*4;
a[2]=0;
}
}
else if(yu==1)
{
if(a[2]>=1)
{
a[2]-=1;
a[1]-=3;
}
else
a[1]-=9;
}
}
if(a[2]>0)
{
cnt+=(a[2]-1+9)/9;
a[2]%=9;
a[1]-=36-a[2]*4;
}
if(a[1]>0)
{
cnt+=(a[1]-1+36)/36;
}
printf("%d\n",cnt);
}
return 0;
}





最新文章

  1. 转载文章——从HelloWorld学习操作系统
  2. python logging 模块
  3. PHP定界符 heredoc
  4. sqlmap.config 配置
  5. ecshop获取浏览器各个版本
  6. JQ 操作样式,单选按钮跟复选框
  7. json格式化和查看工具
  8. html5的video标签自动播放
  9. win10每次开机都显示&ldquo;你的硬件设置已更改,请重启电脑&hellip;&hellip;&rdquo;的解决办法
  10. 关于” 记一次logback传输日志到logstash根据自定义设置动态创建ElasticSearch索引” 这篇博客相关的优化采坑记录
  11. ssh远程连接vm 安装的ubuntu
  12. kafka手动开启监听
  13. 软件破解入门(暴力破解CrackMe)
  14. 截图原理(一)——Android自动化测试学习历程
  15. scrapy中Request中常用参数
  16. 【java】详解java多线程
  17. Android ScrollView嵌套ScrollView滚动的问题解决办法
  18. 线程等待——CountDownLatch使用
  19. git —— bug分支
  20. DAGDGC特殊调弦

热门文章

  1. winform messageBox.Show()
  2. centos中mariadb的相关操作
  3. C#异步编程学习笔记之-async和await
  4. JS基础_相等运算符
  5. O058、Snapshot Volume 操作
  6. luogu P3645 [APIO2015]雅加达的摩天楼
  7. 如何将webstrom本地的代码上传到github上
  8. WebStorm 启动时提示Failed to load JVM DLL
  9. 【转】草根老师的 linux字符设备驱动详解
  10. telnet命令测试端口连接是否正常, telnet不是内部或外部命令的方案